Foster, ThomasX wrote:

You apparently did try the device hints.. but is your kernel compiled to use that 
hints file?  Also.. if you cat the output of the mouse device.. what do you get?


You mean on the FreeBSD 5.2.1-p9 box? If so, check below:


machine         i386
cpu             I486_CPU
cpu             I586_CPU
cpu             I686_CPU
ident           THRAWN

#To statically compile in device wiring instead of /boot/device.hints
#hints          "GENERIC.hints"               #Default places to look for devices.

makeoptions     DEBUG=-g                #Build kernel with gdb(1) debug symbols

options         SCHED_4BSD              #4BSD scheduler
options         INET                    #InterNETworking
options         FFS                     #Berkeley Fast Filesystem
options         SOFTUPDATES             #Enable FFS soft updates support
options         UFS_DIRHASH             #Improve performance on big directories
options         MD_ROOT                 #MD is a potential root device
options         NFSCLIENT               #Network Filesystem Client
options         MSDOSFS                 #MSDOS Filesystem
options         CD9660                  #ISO 9660 Filesystem
options         PROCFS                  #Process filesystem (requires PSEUDOFS)
options         PSEUDOFS                #Pseudo-filesystem framework
options         COMPAT_43               #Compatible with BSD 4.3 [KEEP THIS!]
options         COMPAT_FREEBSD4         #Compatible with FreeBSD4
options         SCSI_DELAY=5000         #Delay (in ms) before probing SCSI
options         KTRACE                  #ktrace(1) support
options         SYSVSHM                 #SYSV-style shared memory
options         SYSVMSG                 #SYSV-style message queues
options         SYSVSEM                 #SYSV-style semaphores
options         _KPOSIX_PRIORITY_SCHEDULING #Posix P1003_1B real-time extensions
options         KBD_INSTALL_CDEV        # install a CDEV entry in /dev
options         AHC_REG_PRETTY_PRINT    # Print register bitfields in debug
                                        # output.  Adds ~128k to driver.
options         AHD_REG_PRETTY_PRINT    # Print register bitfields in debug
                                        # output.  Adds ~215k to driver.
options         PFIL_HOOKS              # pfil(9) framework

device          isa
device          pci

# ATA and ATAPI devices
device          ata
device          atadisk                 # ATA disk drives
device          atapicd                 # ATAPI CDROM drives
options         ATA_STATIC_ID           #Static device numbering

device          atapicam
device          scbus                   # Needed for CAM device
device          pass                    # Needed to connect scsi to cam
device          cd                      # SCSI cd connected through CAM

# atkbdc0 controls both the keyboard and the PS/2 mouse
device          atkbdc          # AT keyboard controller
device          atkbd           # AT keyboard
device          psm


I don't know exactly if I have done it right but I should check "/boot/devices.hints" for input right?

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Mattias Björk
Sent: Thursday, August 19, 2004 2:30 PM
Subject: Re: Mouse problems with KVM switch



From: thrawn <[EMAIL PROTECTED]>
Date: Thursday, August 19, 2004 6:18 am


I have just brought this KVM switch:

But Im having major problems with getting the mouse to work under FreeBSD. Even the keyboard does not work sometimes. This KVM switch has support for hotkey and also supports emulation on both mouse and keyboard.
When I boot up my system and see the BIOS on the computer the keyboard works just fine. Then when it continues to boot and comes to the loader, it still works. And the it starts to load the kernel. But then when i get to the login prompt the keyboard does not work.

And sometimes even thought I stay with the computer the hole boot process I can't even use the keyboard. So I have to use ssh to login to the computer and make it reboot to regain the keyboard. I have also tried to change the cables but I get the same results. And It works with no problems under Windows XP Pro.

The system that im using is FreeBSD 5.2.1-p9, at least on this system.

I have also two other computers that Im running FreeBSD-stable on. On one of my FreeBSD-stable machines I have hade a working mouse under X Windows System (Xorg latest from ports).

But then I rebooted the system and when I started xdm, it found the mouse but when I move it around It didn't move like it should. It took some seconds before it moved and it did not move like it should, jumps several ramdom cm/inches on the screen (Perhaps in the direction that I move the mouse im not sure). Its on usable in other words.

I have also tryied to use moused under FreeBSD but I get the same fault/problem. I also have a problem if I do not have this machine selected when I boot. Then when I switch to it when the boot of the FreeBSD system has complete, The screen on the monitor just blinks.

Still the keyboard works because I can press two times Left Ctrl and then 1 to 4 to change the computer Im controlling. This I can not do with the FreeBSD 5.2.1-p9 system I can only see the screen but have to change the computer im controlling by pressing the button on the switch box.

I have tried to remove the cables and put them back again. But that does not help, the only solution I can see is to reboot the system and let it boot with it selected. I have also booted up with the mouse directly connected to the computer. Then when the system boot was completed I moved the mouse around to see that it did work. After that I plugged back the cable from the switch in to the computers mouse port. And the plugged the mouse back in the switch box, that did not work either.

I have also added flags to both psm0 and atkbd in my kernel config:

# atkbdc0 controls both the keyboard and the PS/2 mouse
device          atkbdc0 at isa? port IO_KBD
device          atkbd0  at atkbdc? irq 1 flags 0x0
device          psm0    at atkbdc? irq 12 flags 0x0

I have also tried with the flags set to 0x100 on both atkbd0 and psm0, but that doesn't seem to make any diffrance. I have done this on my FreeBSD 5.2.1-p9 box as well. I have also changed it in:


But I don't get it working correctly either by that.

Does anybody have a clue or have hade any similar problems and/or who could shine some light on this problem?

Mvh Mattias Björk

Aloha Mattias

This all sounds familiar. I too had a lot of trouble
with a KVM switch. Actually, I tried two with the same
problem you are alluding to.

Does your KVM support hotkey? I have another KVM switch erlier that did work better but It didn't have support for hotkey. But It did not work perfectly but atleast the mouse worked mutch better if you compare to this.

I came to the conclusion that the mouse will not work
through the KVM switch using FBSD, or at least I never
got it to.

Im afraid that I can only agree. I have googled some also and there are quite a few posts that have the same topic. Some some years old. Not to blame FreeBSD but it seems that its a common problem. Or perhaps the KVM that I have been using are Crap or something in that direction.

I have two computers that are both running 5.2.1

I have two with FreeBSD-Stable and one with 5.2.1-p9.

I have connected a mouse directly to each computer.
I still had to shutdown both computers and connect the cables for the monitor and keyboard from each to
the KVM. I also connected and old mouse to the output
of the KVM.

I know that is a solution, don't need the mouse for the most of the time on the servers. But my Workstation Its requierd. Then again its kind of dumb to have a KVM if you still have to use the mouse directly connected to the computer.

With all this connected, I then powered up both computers. All seems to work fine with 
the inconvenience
of having to use 2 meese. I seldom have to go into one
fo the computers, so I can live with it.

As I still can return the KVM im thinking that I should do it. But not until I have gotten more mail about this issue. Im not convinced yet, so I can wait a week or so.

This is probably not the answer you were looking for
but you were also looking for others who had problems.

Well its because I wanted to know if other have hade the same issues. What is the brand and model of your KVM?

Best of Luck

Thanks for your reply.

Mvh Mattias Björk
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Thanks for the answer.

Mvh Mattias Björk
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to