On Wed, Aug 25, 2004 at 09:11:51AM +0300, Cristi Tauber wrote:
>          hi all,
>     I compile a 5.2.1 release's kernel with IPFIREWALL and IPSEC (?
> IPSEC_ESP). I compiled the kernel w/o errors i rebooted and everything
> works great. I mention that I do not installed any IPSEC software at
> that time. I downloaded qmail ? ucspi and try to install. After ucspi I
> had to reboot the server in order to start svscan. Now is my problem ...
> the server is not booting with the error :
>  /etc/rc: WARNING : /etc/ipsec.conf not readable; ipsec start aborted
>   (OK ... i dont want ipsec right now)
> ERROR: ABORTING BOOT (sending SIGTERM to parent)!
> /bin/sh on /etc/rc terminated abnormally, going to single mode
>            A tried to recompile the kernel without IPSEC and even
> without IPFIREWALL ... i get the same error . What's wrong ???
>                      thanks in advance
>             Cristi

I really don't know anything about using IPSEC under FreeBSD, but since
nobody seems to have replied just yet, I'll offer up a few suggestions
that occur to me immediately ( in order of importance ):

1) in /etc/rc.conf set ipsec_enable="NO" - take a look at
/etc/rc.d/ipsec, you'll see that it may be this script that is causing
your boot to fail under the ipsec_prestart() function. so setting this
option in rc.conf may well give you the desired result.

2) try creating an empty /etc/ipsec.conf to appease ipsec

3) check into any sysctl variables that might affect ipsec in the kernel
- set them in either /etc/sysctl.conf, or perhaps /boot/loader.conf.

PGP Public Key: pgp.mit.edu:11371/pks/lookup?op=get&search=0xD8527E49

Attachment: pgpvBVhaWr1eE.pgp
Description: PGP signature

Reply via email to