Vaughan Moore wrote:

I'm a complete newbie and I'm trying to set up X server on a Toshiba
Satellite pro 4620dvd laptop.  Everytime I run through xf86cfg or
xf86cfg -textmode I get the error message "The XFree86 configuration process
seems to have failed.  Would you like to try again?"  Obviously, this is a
bit frustrating.

Sounds like it. Wonder why? Are you running the program with root privileges? (You should be...)

Here are what I think are the valid parts of the XF86Config file, but I may
be missing something - please let me know.

        Driver = "mouse"
        Option = "Protocol" "Auto"
        Option = "Device" "/dev/sysmous"
        Driver "Keyboard"
        Option "Skbmode1" "pc101" (note: my laptop only has 85 keys"
        Option "XkbLayout "us"
        HorizSync 31.5-31.5
        VertRefresh 50.0-70.0
        Driver "s3"
        VendorName "S3 Inc."
        BoardName "86C270-294 Savage/IX-MV"
        ChipSet "SuperSavage/IX64"
        BusID "PCI:1:0:0"
        Default Depth 8
        Display Depth 1
        Display Depth 4
        Display Depth 8
        Modes "640x480"
        Display Depth 15
        Display Depth 16
        Display Depth 24

My main questions are:

1) The Toshiba documentation and Web site do not tell me what my internal
monitor's horizontal sync or vertical refresh rate is. (although it does
give me refresh rates for an external monitor - 60/75/85 @16M colors).  Is
there a place I can go to find this information?

Well, this is pretty common. Many desktop monitors don't give such information, either, and you either Google for it or guess, usually. What happens if you call "startx", or have you?

2) Are there other obvious reasons the configuration would fail other than
the monitor?

The most obvious one I can think of is that, IIRC, the driver for the Savage chipsets is "savage", not "s3". But I could be wrong; can't remember ever trying X with the "savage" driver. Have you tried the "vesa" driver? Might do something for ya...

Secondly, your Horizontal sync range isn't a range.  Perhaps opening
that up a bit would allow you to try it out.

Certainly there could be other issues as well. I mentioned permissions
above, for one. If you have the above in /etc/X11R6/XF86Config, if you
run "startx" you should get either a server running or some error output
in /var/log that might help...OTOH, I've never set up X on any laptop; I
don't know if it's unsafe to try with a relatively untested config file. But
the values look sane enough for a CRT display ...

3) Are there any sites I can visit for more info?

XFree's site at; the FreeBSD handbook at
come to mind.

Thanks so much!

You are welcome.

Vaughan Moore

Also, did I post this to the right list? If not, please let me know where
it should go.

Works for me.

Kevin Kinsey
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to