Yes, I ran pkgdb -F (I didn't use f, don't know what it's for yet).
I fixed those dependencies.
And yep, I have Qt 3.3.3
I'll have to look at arts...



On Tuesday 31 August 2004 05:12 pm, Donald J. O'Neill wrote:
> I took this from the announcement on the ports list:
> Packages are available for i386 for 4-STABLE and 5-CURRENT
> (5.3-BETA) from
> http://rabarber.fruitsalad.org
>
> Did you run pkgdb -fF? As I said before, I had to fix the broken
> dependencies on kdelibs and kdepim before "portupgrade -pv kde\*
> quanta\*" would work.
>
> Do you have qt-3.3.3 installed on your systems. You need to have
> that. If not, install it first. Do you have arts-1.3.0,1 installed.
> if not, install that next, it has a dependency on qt in order to
> build from ports. Then install kdelibs-3.3.0, from ports. It has
> dependency on qt and arts in order to build. After that try
> upgrading using portupgrade, or if you have truly trashed kde,
> build kde-3.3.0, the meta port. Then, build any other kde ports you
> need.
>
> I run FreeBSD 5.2.1p9. There aren't any kde packages for it yet,
> maybe there are now, well I know there are, I built them and
> they're sitting on my system, but they not generic built.
>
> Don
>
> --
> Donald J. O'Neill
> [EMAIL PROTECTED]
>
> --------------------------------------------
>
> On Tuesday 31 August 2004 03:26 pm, Steven Friedrich wrote:
> > Thanks for the info.
> >
> > I added CFLAGS and COPTFLAGS to my make.conf, but it still fails
> > to build kdelibs on two machines.  This looks like a valid build
> > break to me.  Did you build it on 4.x or 5.x?
> >
> > I suspect it's due to the compiler on 4.x.  Did the KDE port team
> > build it on 4.10-STABLE?
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to