On Friday 03 September 2004 01:43 am, Matthew Seaman wrote:
> One thing to check -- do you have the machine key for the remote
> machine cached somewhere


> Failing that, try running ssh and/or sshd in debug mode.  On the
> client side you can run:
>     % ssh -v -v -v [EMAIL PROTECTED]
> which will trace exactly what ssh is trying to do as you log in.

Not much, it seems. Never makes contact:

$ ssh -v -v -v [EMAIL PROTECTED]
OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090701f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug2: ssh_connect: needpriv 0
debug1: Connecting to [host] [host ip] port 22.
debug1: connect to address [host] port 22: Connection timed out
ssh: connect to host [host] port 22: Connection timed out

The ssh_config has 'ForwardX11 yes' but is default apart from that. 
Unfortunately I don't have root access on the remote box.

What's odd is that it never tries to contact me on port 22. I'm logging all 
packets from it to me, and I'm only seeing packets _from_ its port 22 to one 
of my unpriveledged ports (I should have added before that I'm first sshing 
to this computer, then trying to ssh back). I also just tried this from 
another remote computer (OpenSSH_3.7.1p2) on a completely separate network 
2000 miles away, and got the exact same results. (For fun I tried sshing 
between these two remote computers, and that works fine.)

I'd suggest that port 22 is being blocked upstream, but I just ssh'd to an old 
computer that sits right next to my desktop and is on the same network (it 
runs 5.2RC2). That computer can't ssh to mine either.


+++ Divide By Cucumber Error. Please
Reinstall Universe And Reboot. +++
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to