Andrew L. Gould wrote:
On Friday 03 September 2004 03:56 pm, Norm Vilmer wrote:

I am having trouble burning an iso image to a CD-R using FreeBSD
4.10. I have tried using
burncd , cdrecord, and  growifofs, all appear to have basically the
same problem (see details below)
"Operation not permitted". The only thing bugs me is dmesg reports my
drive as a DVD-R.
I am not sure if this is the problem or how to addressing correcting
it if it is. Note: the BIOS
report the drive to be TOSHIBA DVD-ROM SD-R6112 1031.

Can anyone give me some direction as to what I should try next, or
better, I can the burner working?


FYI: I read the CD-Writing Howto and several other articles and
followed the instructions therein to the best of my ability (you be
the judge). This included:

- logging in as root;
- adding "device atapicam"  to the kernel configuration and
rebuilding the kernel;
- creating /etc/devfs.conf as follows:

link    acd0    cdrom
link    acd0    dvd
perm    acd0    0660
perm    cd0     0660
perm    pass0   0660
perm    pass1   0660
perm    pass2   0660
perm    pass3   0660
perm    xpt0    0666

Once atapicam is installed, the CDROM device should have changed from /dev/acd0c to /dev/cd0c. From my pc:
ls -alh /dev/cd0c
crw-r----- 2 root operator 15, 2 May 27 12:17 /dev/cd0c

- installing cdrecord, dvd+rw-tools
- ensure that the drive can read CD's and DVDs
- running ./MAKEDEV pass10 in the /dev directory

also added these


to /boot/loader.conf

mount -t cd9660 /dev/cd0 /cdrom         # works fine CD's and DVD's

Here's some things I tried:

burncd -f /dev/acd0c -s 12 data 5.2.1-RELEASE-i386-disc1.iso fixate
burncd: open(/dev/acd0c): Operation not permitted

Once you have atapicam working, burncd should not work. Also, as per above, /dev/acd0c should no longer represent the CDROM.

cdrecord -scanbus
Cdrecord 2.00.3 (I386 .....
cdrecord: Operation not permitted. Error opening /dev/pass0 Cam error
'camreal_ opendevice: coundn't open passthr. Cannot open SCSI driver.

growisofs -dvd-compat -speed=4 -Z

:-( unable to cam_open_pass("/dev/pass0", O_RDWR): Operation not
: permitted.

dmesg |grep DVD
acd0: DVD-R <TOSHIBA DVD-ROM SD-R6112> at ata1-master UDMA33
cd0: <TOSHIBA DVD-ROM SD-R6112 1031> Removable CD-ROM SCSI-0 device

atacontrol list
ATA channel 0:
        Master: ad0 <TOSHIBA MK8026GAX/PA001G> ATA/ATAPI rev 6
        Slave:  no device present
ATA channel 1:
        Master: acd0 <TOSHIBA DVD-ROM SD-R6112/1031> ATA/ATAPI rev 5
        Slave:  no device present

camcontrol devlist
<TOSHIBA DVD-ROM SD-R6112 1031>   at scbus1 target 0 lun 0 (pass0, cd0)


MB:       VIA EPIA-CL10000, 512MB RAM, Award BIOS 6.00pw
Burner:   Toshiba SD-R6112 DVD-RW

I think the fact that the DVD-ROM is in the camcontrol devlist indicates that atapicam is working. The question remains as to why 'cdrecord -scanbus' didn't work.

1. Are you sure the DVD-RW also burns CD's?
2. Do you know if anyone has gotten this Toshiba model to burn DVD-RW's using FreeBSD?

Good luck,

Andrew Gould

I reviewed the drives specs, and it does burn CD-R's and CD-RW's in addition to DVD's. I will do another post asking if anyone else has gotten this burner to work with FreeBSD.

Do you know if there is a way to bet a more verbose message (why the operation is not permitted) or to debug this problem (I am confortable working with C/C++ but have never looked any FreeBSD source)?

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to