Norm Vilmer wrote:

Richard Lynch wrote:

cdrecord -scanbus
Cdrecord 2.00.3 (I386 .....
cdrecord: Operation not permitted. Error opening /dev/pass0 Cam error
'camreal_
opendevice: coundn't open passthr. Cannot open SCSI driver.



I dunno about all this other stuff, but to me, *THIS* looks like you don't
have the IDE-SCSI module installed.


The IDE-SCSI module "fools" the OS into believing your IDE CDRW device is
"really" a SCSI device.

Without that, cdrecord can't work, since it works through the SCSI interface.

Under RedHat, you would find/download/install the ide-scsi software, and
then do "insmod ide-scsi"

You might also need to make some devices /dev/pg0 etc -- It's all in an
FAQ somewheres for cdrecord.

I gather from my minimal experience with FreeBSD that you'd be doing
something more like pkgload (?) but the principle remains the same:  You
need a module to "fool" the OS into believing your CD/DVD burner is SCSI
when it's not, or cdrecord simply won't talk to it.


cd0: <TOSHIBA DVD-ROM SD-R6112 1031> Removable CD-ROM SCSI-0 device



This, however, indicates that it *IS* a SCSI device...

And its number is "0"

In which case, I would start with:

cdrecord dev=0,0,0 -data whatever.iso


<TOSHIBA DVD-ROM SD-R6112 1031> at scbus1 target 0 lun 0 (pass0, cd0)



Whoops!

Also try:

cdrecord dev=1,0,0 -data whatever.iso

as it seems to be on bus 1.

Do all of this as 'root' If you can get it to work as root, then evaluate
how badly you need it to work for other users, and what "holes" you open
up to do so.


I am logged in as root. Tried cdrecord dev=1,0,0 -data (it is on bus 1)
but I get the same error message. Also, tried setting the permissions
on acd* cd* xpt* pass* devices in /dev. No change. I really get this
feeling the OS thinks it is a read-only drive.

When FreeBSD is installed, it gets some information from the BIOS.
Lots of important stuff like the geometry of your hard drive, etc.
If the BIOS is reporting this wrong or not the same way FreeBSD
see a device, things can break. Is there a flag somewhere I can
flip so that the OS know it can write to this device (the DVD-RW)?


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"


I am burning a cd!!!!
The problem was kern.securelevel=2. Set to 1, and it works great.

Thanks to everyone that responded.

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to