On Saturday 11 September 2004 04:04 am, Travis Troyer wrote:
> I just installed FreeBSD from the 5.2.1 ISO.  After installing
> the necessities, I downloaded the latest ports.tar.gz from
> freebsd.org, extracted the ports, and did a "make index" from
> the ports directory.  At this point I did "make install" from
> x11/kde3.  Since then I have installed firefox, gaim, and a
> few other ports.  Then, I noticed that I didn't have kmail,
> and found that it is part of the kdepim port, so I tried
> installing it.  At some point it requires gpg-error.1, during
> which I get:
>
> ===>   libgcrypt-1.2.0_1 depends on shared library:
> gpg-error.1 - not found
> ===>    Verifying install for gpg-error.1 in
> /usr/ports/security/libgpg-error
> ===>  Vulnerability check disabled
>
> >>libgpg-error-1.0.tar.gz doesn't seem to exist in
>
> /usr/ports/distfiles/.
>
> >>Attempting to fetch from
>
> ftp://gd.tuwien.ac.at/privacy/gnupg/libgpg-error/.
> Receiving libgpg-error-1.0.tar.gz (323724 bytes): 100%
> 323724 bytes transferred in 24.9 seconds (12.68 kBps)
> ===>  Extracting for libgpg-error-1.0
>
> >>Checksum OK for libgpg-error-1.0.tar.gz.
>
> ===>  Patching for libgpg-error-1.0
> ===>   libgpg-error-1.0 depends on file:
> /usr/local/bin/libtool15 - found
> ===>   libgpg-error-1.0 depends on shared library: intl - found
> ===>  Configuring for libgpg-error-1.0
> cp: /usr/ports/security/libgpg-error/work/libgpg-error-1.0
> /usr/ports/security/libgpg-error/work/libgpg-error-1.0/config.guess:
> No such file or directory
> *** Error code 1
>
>
> When installing other ports, I find that I get similar errors,
> involving a "config.guess" file.
>
> Trying various things, I decided to run "portsdb -Uu", and got:
>
> portsdb -Uu
> Updating the ports index ... Generating INDEX.tmp - please
> wait..Warning: Duplicate INDEX entry: freeciv-gtk2-1.14.1
> Done.
> done
> [Updating the portsdb <format:bdb1_btree> in /usr/ports ... -
> 11735 port entries found
> .........1000.........2000.........3000.........4000.........5000....
>.....6000.........7000.........8000..../usr/local/lib/ruby/site_ruby/1
>.8/portsdb.rb:587: [BUG] Bus Error
> ruby 1.8.2 (2004-07-29) [i386-freebsd5]
>
> Abort (core dumped)
>
>
>
> At this point I am completely clueless as to what to try next.
> I can't seem to install any ports, and I don't know how to
> get my ports collection back to a usable state, or what I did
> to break it in the first place.  Of course, I will be happy to
> provide any addition information.  I would appreciate any help
> that may be offered.
>

In

http://docs.freebsd.org/cgi/getmsg.cgi?fetch=638936+0+current/freebsd-ports

The port maintainer suggests setting ENV['PORTS_DBDRIVER'] = 'dbm_hash' 
in your /usr/local/etc/pkgtools.conf

Then you can create an INDEX.db that you can use.

Kent


-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
Support the Bison at http://www.buffalofieldcampaign.org/
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to