in message <[EMAIL PROTECTED]>,
wrote cry stone thusly...
> after installed apache + mysql + php from port,when i run startx i got
> "/libexec/ Shared object not found, required
> by"

X Windows has nothing to do w/ apache, mysql, or php.

How did you install last three pieces of software anyway?

> i google it find that because the expat was upgrade to
> expat-1.95.7,and the is instead by,so
> i run portupgrade -rf textproc/expat2

You need to recompile all the software that was dependent on so that it would be dependent on

In the mean time, see if a link from to
would satisfy the failing applications.  That did work for me until
i had the time to recompile the depending software.

For the next time, remember to upgrade depending software when
you upgrade dependency software.

I personally stay away from using portupgrade to actually do
upgrade; wait for others to resolve your issues w/ portupgrade.

> and make world but it still failed.

Wow, that is really unnecessarily excessive!

You can upgrade ports software from the ports w/o the need of
upgrading the base system.  (In most cases anyway.  Sometimes one
would need to upgrade base system *eventually* to be able to
build/install software from ports.  But that's another thread.)

  - Parv


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to