Richard P. Williamson wrote:
On Tue, Sep 14, 2004 at 09:14:00PM -0600, Gary Aitken wrote:

This has to be covered in the docs somewhere, but my searches there
and on questions, hackers, and fs turned up zip.

Installed an old pcmcia card device,
plugged in a flashcard reader w/card.

4.10
kernel contains
 device ata
 device card
 device pcic0
rc.conf contains
 pccard_enable="YES"

I see
 pccard: card inserted, slot 1
 ...pccardd[52]: Card "SunDisk"("SDP") [5/3 0.6] [[none]]
 matched "SunDisk" ("/.*/") [(null)] [(null)]
 ata1 at port 0x240-0x247,0x24e irq 10 slot 1 on pccard1
 ...pccardd[52]: ata1: SunDisk (/.*/) inserted.

So far, so good...

Now, I thought one should be able to read these as a file system.

If so, to what device does one mount?  I tried the ata device,
but get the message "Block device required"; and there are no other
ata entries in /dev.  Do I need to manually create these?

If not, what's the procedure for reading?


What kind of hardware? When using a FreeBSD 4.10 laptop, my CF
cards come up on /dev/ad8 when plugged into a CF holder and
then into the PCMCIA slot. I've also got a 4.10 desktop with a PCMCIA add-on ATA device (ie, plugged into IDE1, slave). It comes up as /dev/ad3. The desktop however does not support
hot swapping pcmcia devices.

micronics M54Hi-Plus mobo, p200, 128M buslogic bt-946c scsi ctlr (bt driver) (2) smc etherpower nic (dec 21041) (de driver) ne2000 compatible nic (ed driver) isa board for pcmcia; has Vadem 365 chips on it.

Made a little progress...

Discovered that because the original system had no ata devices,
the installation had generated a /boot/kernel.conf that disabled
ata devices.  Removing that line helped.

The card now comes up:

ad0: 15MB <SanDisk SDCFB-16> [490/2/32] at ata0-master BIOSPIO

However, when I try to mount the thing I get:

/#mount /dev/ad0 /pccard
mount: /dev/ad0 on /pccard: incorrect super block

What type of file system do the cards have on them?
I tried mount_msdos and that didn't work;
got "/dev/ad0: Invalid argument"

Don't know if this is related or not:

The boot probe shows the following:
...
isab0: <Intel 82371SB PCI to ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX3 ATA controller> at device 7.1 on pci0
atapci0: ATA channel disabled by BIOS
...

I presume this is the ata primary and secondary disk connectors
being reported as disabled, not the isa bus card slots.  I do
have the ide disks disabled in BIOS, as there are no ide drives
on the system.

Thanks for any insights,

Gary
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to