Vonleigh Simmons wrote:
I keep struggling with this without finding a way of fixing it. Whenever I link in mod_php into httpd.conf (loadmodule and addmodule), apache fails to start up. I can get it to work by commenting mod_php it out, starting up apache, then commenting it back in and restarting. If I restart once more, then it segfaults again. In the logs I occasionally get:

[notice] child pid 17255 exit signal Segmentation fault (11)

I've tried installing (and reinstalling) apache13-modssl, apache13-modperl, reinstalling /usr/ports/www/mod_php4, compiling apache without expat, checking ldd:

/usr/local/libexec/apache/libphp4.so:
        libcrypt.so.2 => /lib/libcrypt.so.2 (0x28248000)
        libm.so.2 => /lib/libm.so.2 (0x28261000)

/usr/local/libexec/apache/libphp4.so:
        libcrypt.so.2 => /lib/libcrypt.so.2 (0x28248000)
        libm.so.2 => /lib/libm.so.2 (0x28261000)

So far nothing has been successful. I even tried installing apache2 to see if that would work, and although it does for the most part, it crashes when using the php mail() function.



This happens from time to time and I've no idea why, but hitting it with a lump hammer, as follows, seems to fix it for me.


1. deinstall php or mod_php, depending on how you installed it initially
2. manually delete /usr/local/include/php
3. manually delete /usr/local/share/pear if it's there
4. manually delete /usr/local/libexec/apache/libphp4.so if it's still there
5. reinstall php

HTH

Peter.
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to