You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     r...@freebsd.org
Last committer: lini...@freebsd.org
Ident:          $FreeBSD: head/devel/rubygem-gobject-introspection/Makefile 
422369 2016-09-18 10:47:08Z linimon $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/422472/logs/rubygem-gobject-introspection-3.0.8.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=422472
Log:

====>> Building devel/rubygem-gobject-introspection
build started at Tue Sep 20 08:03:31 UTC 2016
port directory: /usr/ports/devel/rubygem-gobject-introspection
building for: FreeBSD 93amd64-default-job-22 9.3-RELEASE-p45 FreeBSD 
9.3-RELEASE-p45 amd64
maintained by: r...@freebsd.org
Makefile ident:      $FreeBSD: 
head/devel/rubygem-gobject-introspection/Makefile 422369 2016-09-18 10:47:08Z 
linimon $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 9.3-RELEASE-p45
UNAME_r=9.3-RELEASE-p45
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
ARCH=amd64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=rubygem-gobject-introspection-3.0.8
OSREL=9.3
_OSRELEASE=9.3-RELEASE-p45
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
HAVE_COMPAT_IA32_KERN=YES OPSYS=FreeBSD
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work  
HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
GI_SCANNER_DISABLE_CACHE=1 
XDG_CACHE_HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work  
HOME=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work TMPDIR="/tmp" 
NO_PIE=yes WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 
-pipe -fstack-protector -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/2.2"
RUBY_ARCHLIBDIR="lib/ruby/2.2/amd64-freebsd9"
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.2"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.2/amd64-freebsd9"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.2"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.2/amd64-freebsd9"
RUBY_MODDOCDIR="share/doc/ruby22/gobject-introspection"
RUBY_MODEXAMPLESDIR="share/examples/ruby22/gobject-introspection"
RUBY_DOCDIR="share/doc/ruby22"
RUBY_EXAMPLESDIR="share/examples/ruby22"
RUBY_RIDIR="share/ri/2.2/system"
RUBY_SITERIDIR="share/ri/2.2/site"
RUBY_VERSION="2.2.5"
RUBY_VER="2.2"
RUBY_SHLIBVER="22"
RUBY_ARCH="amd64-freebsd9"
RUBY_SUFFIX="22"
RUBY_NAME="ruby22"
RUBY_DEFAULT_SUFFIX="22"
RUBY21="@comment
"
RUBY22=""
RUBY23="@comment
"
PORTVERSION="3.0.8"
REV=""
GEMS_BASE_DIR="lib/ruby/gems/2.2"
GEMS_DIR="lib/ruby/gems/2.2/gems"
DOC_DIR="lib/ruby/gems/2.2/doc"
CACHE_DIR="lib/ruby/gems/2.2/cache"
SPEC_DIR="lib/ruby/gems/2.2/specifications"
EXT_DIR="lib/ruby/gems/2.2/extensions"
PORT="gobject-introspection-3.0.8"
GEM_NAME="gobject-introspection-3.0.8"
GEM_LIB_DIR="lib/ruby/gems/2.2/gems/gobject-introspection-3.0.8"
GEM_DOC_DIR="lib/ruby/gems/2.2/doc/gobject-introspection-3.0.8"
GEM_SPEC="lib/ruby/gems/2.2/specifications/gobject-introspection-3.0.8.gemspec"
GEM_CACHE="lib/ruby/gems/2.2/cache/gobject-introspection-3.0.8.gem"
EXTRACT_SUFX=".gem"
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/gobject-introspection"
EXAMPLESDIR="share/examples/gobject-introspection"
DATADIR="share/gobject-introspection"
WWWDIR="www/gobject-introspection"
ETCDIR="etc/gobject-introspection"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gobject-introspection
DOCSDIR=/usr/local/share/doc/gobject-introspection
EXAMPLESDIR=/usr/local/share/examples/gobject-introspection
WWWDIR=/usr/local/www/gobject-introspection
ETCDIR=/usr/local/etc/gobject-introspection
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubygem-gobject-introspection-3.0.8 depends on file: /usr/local/sbin/pkg 
- not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[93amd64-default-job-22] Installing pkg-1.8.7_3...
[93amd64-default-job-22] Extracting pkg-1.8.7_3: .......... done
===>   rubygem-gobject-introspection-3.0.8 depends on file: /usr/local/sbin/pkg 
- found
===>   Returning to build of rubygem-gobject-introspection-3.0.8
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21+ accepted by the user
===> Fetching all distfiles required by rubygem-gobject-introspection-3.0.8 for 
building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21+ accepted by the user
===> Fetching all distfiles required by rubygem-gobject-introspection-3.0.8 for 
building
=> SHA256 Checksum OK for rubygem/gobject-introspection-3.0.8.gem.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/ruby22 - not found
===>   Installing existing package /packages/All/ruby-2.2.5,1.txz
[93amd64-default-job-22] Installing ruby-2.2.5,1...
[93amd64-default-job-22] `-- Installing libedit-3.1.20150325_2,1...
[93amd64-default-job-22] `-- Extracting libedit-3.1.20150325_2,1: .......... 
done
[93amd64-default-job-22] `-- Installing libyaml-0.1.6_2...
[93amd64-default-job-22] `-- Extracting libyaml-0.1.6_2: ......... done
[93amd64-default-job-22] `-- Installing libexecinfo-1.1_3...
[93amd64-default-job-22] `-- Extracting libexecinfo-1.1_3: ..... done
[93amd64-default-job-22] `-- Installing libffi-3.2.1...
[93amd64-default-job-22] |   `-- Installing indexinfo-0.2.5...
[93amd64-default-job-22] |   `-- Extracting indexinfo-0.2.5: .... done
[93amd64-default-job-22] `-- Extracting libffi-3.2.1: .......... done
[93amd64-default-job-22] Extracting ruby-2.2.5,1: .......... done
Message from ruby-2.2.5,1:
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        databases/ruby-gdbm:    GDBM module

Install them as occasion demands.
====
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/ruby22 - found
===>   Returning to build of rubygem-gobject-introspection-3.0.8
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/gem22 - not found
===>   Installing existing package /packages/All/ruby22-gems-2.6.4.txz
[93amd64-default-job-22] Installing ruby22-gems-2.6.4...
[93amd64-default-job-22] Extracting ruby22-gems-2.6.4: .......... done
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/gem22 - found
===>   Returning to build of rubygem-gobject-introspection-3.0.8
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21+ accepted by the user
===> Fetching all distfiles required by rubygem-gobject-introspection-3.0.8 for 
building
===>  Extracting for rubygem-gobject-introspection-3.0.8
=> SHA256 Checksum OK for rubygem/gobject-introspection-3.0.8.gem.
Unpacked gem: 
'/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/gobject-introspection-3.0.8'
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/ruby22 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubygem-gobject-introspection-3.0.8
===========================================================================
=======================<phase: build-depends  >============================
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/ruby22 - found
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/gem22 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   rubygem-gobject-introspection-3.0.8 depends on shared library: 
libglib-2.0.so - not found
===>   Installing existing package /packages/All/glib-2.46.2_2.txz
[93amd64-default-job-22] Installing glib-2.46.2_2...
[93amd64-default-job-22] `-- Installing libiconv-1.14_9...
[93amd64-default-job-22] `-- Extracting libiconv-1.14_9: .......... done
[93amd64-default-job-22] `-- Installing python27-2.7.12...
[93amd64-default-job-22] |   `-- Installing gettext-runtime-0.19.8.1...
[93amd64-default-job-22] |   `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[93amd64-default-job-22] `-- Extracting python27-2.7.12: .......... done
[93amd64-default-job-22] `-- Installing pcre-8.39...
[93amd64-default-job-22] `-- Extracting pcre-8.39: .......... done
[93amd64-default-job-22] `-- Installing perl5-5.20.3_15...
[93amd64-default-job-22] `-- Extracting perl5-5.20.3_15: .......... done
[93amd64-default-job-22] Extracting glib-2.46.2_2: .......... done
No schema files found: doing nothing.
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.20.3_15:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   rubygem-gobject-introspection-3.0.8 depends on shared library: 
libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   Returning to build of rubygem-gobject-introspection-3.0.8
===>   rubygem-gobject-introspection-3.0.8 depends on shared library: 
libgirepository-1.0.so - not found
===>   Installing existing package 
/packages/All/gobject-introspection-1.46.0.txz
[93amd64-default-job-22] Installing gobject-introspection-1.46.0...
[93amd64-default-job-22] `-- Installing python2-2_3...
[93amd64-default-job-22] `-- Extracting python2-2_3: ...... done
[93amd64-default-job-22] Extracting gobject-introspection-1.46.0: .......... 
done
===>   rubygem-gobject-introspection-3.0.8 depends on shared library: 
libgirepository-1.0.so - found (/usr/local/lib/libgirepository-1.0.so)
===>   Returning to build of rubygem-gobject-introspection-3.0.8
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubygem-gobject-introspection-3.0.8
===========================================================================
=======================<phase: build          >============================
===>  Building for rubygem-gobject-introspection-3.0.8
  Successfully built RubyGem
  Name: gobject-introspection
  Version: 3.0.8
  File: gobject-introspection-3.0.8.gem
===========================================================================
=======================<phase: run-depends    >============================
===>   rubygem-gobject-introspection-3.0.8 depends on package: 
rubygem-glib2>=3.0.8 - not found
===>   Installing existing package /packages/All/rubygem-glib2-3.0.8.txz
[93amd64-default-job-22] Installing rubygem-glib2-3.0.8...
[93amd64-default-job-22] `-- Installing rubygem-pkg-config-1.1.7_1...
[93amd64-default-job-22] `-- Extracting rubygem-pkg-config-1.1.7_1: .......... 
done
[93amd64-default-job-22] Extracting rubygem-glib2-3.0.8: .......... done
===>   rubygem-gobject-introspection-3.0.8 depends on package: 
rubygem-glib2>=3.0.8 - found
===>   Returning to build of rubygem-gobject-introspection-3.0.8
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/ruby22 - found
===>   rubygem-gobject-introspection-3.0.8 depends on file: 
/usr/local/bin/gem22 - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for rubygem-gobject-introspection-3.0.8
===>   Generating temporary packing list
(cd 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/gobject-introspection-3.0.8;
 /usr/bin/env RB_USER_INSTALL=yes LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 
LC_CTYPE=UTF-8 /usr/local/bin/gem22 install -l --no-update-sources 
--install-dir 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2
 --ignore-dependencies 
--bindir=/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/bin
 --rdoc --ri gobject-introspection-3.0.8.gem -- --build-args )
Building native extensions with: '--build-args'
This could take a while...
ERROR:  Error installing gobject-introspection-3.0.8.gem:
        ERROR: Failed to build gem native extension.

    current directory: 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/gems/gobject-introspection-3.0.8/ext/gobject-introspection
/usr/local/bin/ruby22 -r ./siteconf20160920-51643-7flypv.rb extconf.rb 
--build-args
checking for --enable-debug-build option... no
checking for -Wall option to compiler... yes
checking for -Waggregate-return option to compiler... yes
checking for -Wcast-align option to compiler... yes
checking for -Wextra option to compiler... yes
checking for -Wformat=2 option to compiler... yes
checking for -Winit-self option to compiler... yes
checking for -Wlarger-than-65500 option to compiler... yes
checking for -Wmissing-declarations option to compiler... yes
checking for -Wmissing-format-attribute option to compiler... yes
checking for -Wmissing-include-dirs option to compiler... yes
checking for -Wmissing-noreturn option to compiler... yes
checking for -Wmissing-prototypes option to compiler... yes
checking for -Wnested-externs option to compiler... yes
checking for -Wold-style-definition option to compiler... yes
checking for -Wpacked option to compiler... yes
checking for -Wp,-D_FORTIFY_SOURCE=2 option to compiler... yes
checking for -Wpointer-arith option to compiler... yes
checking for -Wswitch-default option to compiler... yes
checking for -Wswitch-enum option to compiler... yes
checking for -Wundef option to compiler... yes
checking for -Wout-of-line-declaration option to compiler... no
checking for -Wunsafe-loop-optimizations option to compiler... yes
checking for -Wwrite-strings option to compiler... yes
checking for rb_define_alloc_func() in ruby.h... yes
checking for rb_block_proc() in ruby.h... yes
checking for new allocation framework... yes
checking for attribute assignment... no
checking for Windows... no
checking for gobject-introspection-1.0... yes
creating rbgiversion.h
checking for g_interface_info_find_signal() in girepository.h... yes
creating gobject-introspection-enum-types.c
creating gobject-introspection-enum-types.h
creating ruby-gobject-introspection.pc
creating Makefile

To see why this extension failed to compile, please check the mkmf.log which 
can be found here:

  
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/extensions/amd64-freebsd-9/2.2/gobject-introspection-3.0.8/mkmf.log

current directory: 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/gems/gobject-introspection-3.0.8/ext/gobject-introspection
make "DESTDIR=" clean

current directory: 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/gems/gobject-introspection-3.0.8/ext/gobject-introspection
make "DESTDIR="
compiling rb-gi-repository.c
compiling rb-gi-boxed-info.c
compiling rb-gi-argument.c
compiling rb-gobject-introspection.c
compiling rb-gi-property-info.c
compiling rb-gi-callable-info.c
compiling rb-gi-function-info.c
rb-gi-function-info.c:43: error: redefinition of typedef 'RBGICallback'
rb-gobject-introspection.h:31: error: previous declaration of 'RBGICallback' 
was here
*** [rb-gi-function-info.o] Error code 1

Stop in 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/gems/gobject-introspection-3.0.8/ext/gobject-introspection.

make failed, exit code 1

Gem files will remain installed in 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/gems/gobject-introspection-3.0.8
 for inspection.
Results logged to 
/wrkdirs/usr/ports/devel/rubygem-gobject-introspection/work/stage/usr/local/lib/ruby/gems/2.2/extensions/amd64-freebsd-9/2.2/gobject-introspection-3.0.8/gem_make.out
*** [do-install] Error code 1

Stop in /usr/ports/devel/rubygem-gobject-introspection.
_______________________________________________
freebsd-ruby@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ruby
To unsubscribe, send any mail to "freebsd-ruby-unsubscr...@freebsd.org"

Reply via email to