For most of my experience with FreeBSD (since 1998) and for most of my
machines, I build from source (either on the machine itself or a
dedicated "build machine"); this has been ... occasionally turbulent,
but overall, a fairly stable approach for me (and it's a great deal less
turbulent -- usually! -- now than it was a decade ago).

However, I have one machine that is pretty much dedicated to one
specific function, and for it, I thought I'd try freebsd-update.

And over the last year or so, it's worked pretty well:  I have the
machine set up (as is usually my approach) to be able to boot from
either of a couple of slices.  I use a "dump | restore" pipeline
to copy the / and /usr file systems from the "active" slice to the
"inactive" slice, adjust /etc/fstab on the inactive slice to reflect
reality for when it's the boot slice, then (while the file systemms
from the other slice are still mounted -- e.g., on /S2) run
"freebsd-update -b /S2 fetch install", then reboot from the
newly-updated slice.

In the past, that's Just Worked.

This weekend, though, I was planning to update my other systems tfrom
stable/10 to stable/11, so I figured I'd try freebsd-update on this
machine first.

But before I tried going to stable/11, I thought it might be good to
first get to the latest releng/10.

Running freebsd-update seemed to go well.  I rebooted from the updated
slice... and found that I could not ssh to the machine.  (I only
physically login to a machine other than my laptop if there's a problem
that's so bad that I can't login from the laptop....)

And I found that sshd wasn't running.  Indeed, on attempting to start it
by hand:

root@sisboombah: # service sshd start
Performing sanity check on sshd configuration.
Undefined symbol "ssh_compat13" referenced from COPY relocation in 
/etc/rc.d/sshd: WARNING: failed precmd routine for sshd

Attempting to start it in "debug" mode was of no help:

root@sisboombah:/tmp # `which sshd` -d
Undefined symbol "ssh_compat13" referenced from COPY relocation in 

Any clues?

I have placed both a typescript of the freebsd-update run (actually, a
pair of them: one yesterday; another, today), as well as a typescript
from some poking around a bit, under


David H. Wolfskill                    
Those who would murder in the name of God or prophet are blasphemous cowards.

See for my public key.

Attachment: signature.asc
Description: PGP signature

Reply via email to