On Fri, 26 Mar 2010 19:59:15 +0100
Hans Petter Selasky <hsela...@c2i.net> wrote:

> On Friday 26 March 2010 19:34:42 Nicholas 0 wrote:
> > Sometimes when I resume my ThinkPad X200 (Core 2 Duo, 8.0-RELEASE,
> > amd64), my USB ports don't come back online - that is, no power to
> > things that I plug in and nothing shows up in dmesg. Reboot fixes
> > it. It doesn't seem entirely consistent, sometimes USB is fine after
> > suspend, sometimes it isn't.
> > 
> > I'm trying to see if I can find some rhyme or reason as to when this
> > occcurs so I can file a bug report and work with someone to get this
> > fixed, but in the mean time is there any way to reset the USB
> > subsystem/reload the drivers that I can try as a work around? It's
> > annoying having to reboot to charge my phone.
> 
> This use-case has not been tested that much. USB can probably do more
> to recover the state after PC resume.
> 
> --HPS

I tried rebuilding a kernel (latest snapshot of 8-STABLE) without usb
and kldunload/loading (uhci, ehci, usb and all the drivers) on
suspend/resume to see if that would change this behaviour. It does not:
my USB ports are still inactive after resume. The drivers load fine
with no errors that I can see, but there's still no reaction when i plug
something into the USB ports.

For my meagre understanding this would suggest that the bug is not in
the USB drivers, but perhaps in the PCI code. Does that sound
reasonable?

N
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to