The following reply was made to PR usb/77184; it has been noted by GNATS.

From: Yuri <y...@rawbw.com>
To: Cc: bug-follo...@freebsd.org
Subject: Re: usb/77184: [umass] [panic] kernel panic on USB device disconnect,
 even if not detected
Date: Wed, 14 Jul 2010 13:15:22 -0700

 Crash is gone.
 
 But there is something wrong. I did the following steps:
 1. plug the camera into USB and mount it
 2. unplug the camera without unmounting it -- no crash, looks good.
 3. mount still exists. that's ok.
 4. umount /mnt/camera
      -- command says: "Device Busy", this looks reasonable.
 5. umount -f /mnt/camera
      -- mount is gone.
 6. repeated steps 1...4
      on step 4 umount command without -f flag doesn't complain
      about device busy any more. This is really strange and this
      means that device disconnect or unmount hasn't been done
      cleanly and something is different now.
 
 So this issue has to be cleared -- outcome of steps 1..5 should always 
 be the same.
 
 Now after rereading the original post I realize that I am testing the 
 different condition but for quite similar situation. F828 camera isn't 
 available any more and is probably supported by now, so it's really 
 difficult to retest the original condition now.
 
 But my previous post indicates there is the problem in USB stack in the 
 similar scenario, thiugh without unsupported device. Before I saw panic 
 in the case of disconnect of the mounted disk.
 
 
 Yuri
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to