On Sun, 6 Feb 2011, Hans Petter Selasky wrote:

On Saturday 05 February 2011 22:26:03 Benjamin wrote:
The Olimex is a programmer for AVR microcontrollers. It is apparently an
FTDI device and works under Linux. The product page at
http://www.olimex.com/dev/avr-isp500.html provides source code for a
Linux FTDI kernel module.

I have the looked through the Linux FTDI driver source code and have
even been given a patch by a helpful member at the FreeBSD forums
(wblock) but so far no luck.

Here is what it is identified as when plugged in to USB:

Feb  5 13:30:07 blackbox kernel: ugen1.2: <Olimex Ltd.> at usbus1

It should ideally show up as cuaU0 or ttyUSB0 as far as I understand.

A quick search through the Linux driver source code to find all

instances of OLIMEX:
> grep OLIMEX ftdi_*.[c,h]

ftdi_sio_ids.h:#define OLIMEX_VID                       0x15BA
ftdi_sio_ids.h:#define OLIMEX_ARM_USB_OCD_PID           0x0003
ftdi_sio_ids.h:#define OLIMEX_AVR_ISP500_ISO_PID        0x000B

Note that the above is Linux kernel module source. Myself and wblock
have tried to hack the FreeBSD uftdi kernel module to no avail. He
offered the attached patch which did not seem to work.

The Linux driver source is available here:

Does this look like something that could easily be changed in the
FreeBSD uftdi kern module?

Your patch looks OK. Can you create a PR so that your patch doesn't get lost?

I was going to also patch the uftdi man page and submit a PR with all three patches if it worked. But unfortunately, it doesn't. Only vendor ID seems verified so far.
freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to