I'm playing with a built-in webcam here, a Sonix Technology Co CNF9055
with usb-ID 04f2:b1d6.  This ID isn't listed in the webcamd man pages,
but the camera does work... sort of.

If I run webcamd in the foreground, about 7-8 times out of 10, I get:

# /usr/local/sbin/webcamd -d 3.3 -i 0
Attached ugen3.3[0] to cuse unit 0
Creating /dev/video0

And the video works.  Cool!

But sometimes, about 25% of the time, it hangs at:

# /usr/local/sbin/webcamd -d 3.3 -i 0
Attached ugen3.3[0] to cuse unit 0

with no creation of the video device.

If I run it in the background, it fails 100% of the time:

# /usr/local/sbin/webcamd -B -d 3.3 -i 0
Attached ugen3.3[0] to cuse unit -1

which also means it fails to start if webcamd is started from its rc.d
script at boot time.

Webcamd version is 0.1.23, cuse is 0.1.13.  System is 8.2-release amd64.

ugen3.3: <CNF9055 Sonix Technology Co., Ltd.> at usbus3, cfg=0 md=HOST spd=HIGH 
(480Mbps) pwr=ON

  bLength = 0x0012 
  bDescriptorType = 0x0001 
  bcdUSB = 0x0200 
  bDeviceClass = 0x00ef 
  bDeviceSubClass = 0x0002 
  bDeviceProtocol = 0x0001 
  bMaxPacketSize0 = 0x0040 
  idVendor = 0x04f2 
  idProduct = 0xb1d6 
  bcdDevice = 0x2613 
  iManufacturer = 0x0002  <Sonix Technology Co., Ltd.>
  iProduct = 0x0001  <CNF9055>
  iSerialNumber = 0x0000  <no string>
  bNumConfigurations = 0x0001 

What other info can I provide to debug this?

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to