Hi usb people,
Does 8.2-RELEASE support combi printer + scanner ?
Or do I need to install current to get my HP Deskjet 2050 combi scanner
+ printer to work ?

Thanks for any clues.

Forwarded from: "Julian Stacey" <j...@berklix.com> http://www.berklix.com/~jhs/

------- Forwarded Message

To: sane-de...@lists.alioth.debian.org
cc: "m. allan noah" <kitno...@gmail.com>
Subject: Re: [sane-devel] HP Deskjet 2050 special edition 
From: "Julian H. Stacey" <j...@berklix.com>
Organization: http://www.berklix.com BSD Unix Linux Consultancy, Munich Germany
User-agent: EXMH on FreeBSD http://www.berklix.com/free/
X-URL: http://www.berklix.com
In-reply-to: Your message "Thu, 12 May 2011 02:47:53 +0200."
                <201105120047.p4c0lrei083...@fire.js.berklix.net> 
Date: Thu, 12 May 2011 21:54:50 +0200
Sender: j...@fire.js.berklix.net

Hi, I wrote:
> > Hi Sane people,
> > Is "HP Deskjet 2050 special edition" supported ?
> > 
> > I've been trying on FreeBSD-8.2-RELEASE, with sane-backends-1.0.21_2
> > + guidance from 
> > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/scanners.html
> > 
> > I can see & use another scanner (Epson Perfection 1260)
> > 
> > I've been doing some comparisons with both scanners alternately plugged in:
> > 
> > grep ugen /var/log/messages
> >         ugen1.3: <EPSON> at usbus1
> > 
> >         ugen1.3: <HP> at usbus1
> > 
> > su ; sane-find-scanner -q
> >     found USB scanner (vendor=0x04b8 [EPSON], product=0x011d
> >     [EPSON Scanner] , chip=LM9832/3) at libusb:/dev/usb:/dev/ugen1.3
> > 
> >     found USB scanner (vendor=0x03f0 [HP], product=0x8711
> >     [Deskjet 2050 J510 series]) at libusb:/dev/usb:/dev/ugen1.3
> > 
> > ls -l /dev/pass*
> >         crw-------  1 root  operator    0, 141 May 11 19:07 /dev/pass0
> >         crw-------  1 root  operator    0, 121 May  3 15:50 /dev/pass0
> > 
> > su ; scanimage -L
> >     device `plustek:libusb:/dev/usb:/dev/ugen1.3' is a Epson
> >     Perfection 1260 /Photo flatbed scanner
> > 
> >     No scanners were identified.
> > 
> > I've tried adding extra dummy lines in 
> >     sane-backends-1.0.21/tools/hal/libsane.fdi
> >     sane-backends-1.0.21/tools/hotplug/libsane.usermap
> >     sane-backends-1.0.21/tools/udev/libsane.rules
> > 
> > but no luck.
> > 
> > PS Hplip claims to support it:
> > http://hplipopensource.com/hplip-web/supported_devices/deskjet_aio.html
> > http://hplipopensource.com/hplip-web/models/deskjet_aio/deskjet_2050_j510_series
> > html
> > 
> >         Model Name              = HP Deskjet 2050 j510 All-in-one Printer
> >         Min. HPLIP Version      = 3.10.6        
> >                     FreeBSD-8.2 installs print/hplip 3.11.1,
> >                     FreeBSD-current installs 3.11.3


"m. allan noah" replied:

> Do you have HPLIP installed?


Yes as above HP page says 3.10.6 or newer required.
I installed 3.11.1 then 3.11.3

My other Epson scanner is Just a scanner, & works.  The HP is a
combi scanner + printer.  I'm just wondering if that might be a
problem to FreeBSD-8.2-RELEASE, though I recognise that's not a valid
question for this sane list, so I'll ask on an @FreeBSD.org list.

Cheers,
Julian
- -- 
Julian Stacey, BSD Unix Linux C Sys Eng Consultants Munich http://berklix.com
 Mail plain text;  Not quoted-printable, Not HTML, Not base 64.
 Reply below text sections not at top, to avoid breaking cumulative context.

------- End of Forwarded Message

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to