Hi all,

I'm afraid I've also got the infamous error 5 problem on my Macbook.

USB hard drive seems to work fine as it's newfs'd a couple of times,
but after a little while (using USB hard drive as backup destination
with rsync) it gives me these:

[crees@zeus]~% dmesg |tail
g_vfs_done():da0s1[WRITE(offset=41748480, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41750528, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41752576, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41754624, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41756672, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41758720, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41760768, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41762816, length=12288)]error = 5
g_vfs_done():da0s1[WRITE(offset=41775104, length=2048)]error = 5
g_vfs_done():da0s1[WRITE(offset=41777152, length=2048)]error = 5

Unfortunately I can't seem to stop it doing this, and every time I've
just unplugged the drive in the past the system panics... I'd really
rather avoid that since it's my main server.

[crees@zeus]~% uname -a
FreeBSD zeus.bayofrum.net 8.2-RELEASE-p1 FreeBSD 8.2-RELEASE-p1 #0:
Sat Apr 30 15:09:06 BST 2011
r...@zeus.bayofrum.net:/usr/obj/usr/src/sys/ZEUS  i386

Kernel config file is at [1].

I've tried the patch from [2], and this stops the AutoSense failed
messages I used to get, but not these.

Perhaps oddly related, when these messages start tab-completion in
tcsh sometimes hangs -- even for unrelated directories such as % ls
/roo^VTAB causes a hang.

Any ideas/patches/information I've missed? The drive works perfectly
in 'Windows', and I also tried it on my Ubuntu netbook.

Chris


[1] http://www.bayofrum.net/~crees/ZEUS (diff to GENERIC at
http://www.bayofrum.net/~crees/ZEUS.diff)
[2] http://www.freebsd.org/cgi/query-pr.cgi?pr=usb/150401
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to