I recently posted a query on the peripheral hardware forum about a problem
I was having with a Cherry G84-4100 USB keyboard that would not work on my
desktop PC but would work on other computers, including my laptop which has
same version of FreeBSD on it.  The thread can be found here:


The final reply, from wblock, was that the problem was a USB one and should
be posted here.

In fact, I decided to leave it and just use another keyboard.  However,
Santa kindly brought me a Cherry G80-3000 for christmas and this does nor
work either; exactly the same problem occurs with the device not recognised.

These are quite expensive keyboards: not at DAS or Filco prices but
retailing for over £60 in UK and using expensive Cherry switches, so not
some bit of cheap junk that might not cause all that much surprise by not
working.  They are also quite popular so it's hard to believe I'm the only
person using one.

I have got it to work by connecting it to the PS/2 port via an adaptor so
it's not the end of the world.  However, these are unlikely to be supported
for much longer so it would be better if it would work via USB port.  As I
said in the original forum posting, every other USB keyboard I have tried
has worked, both from boot and hot plugged.  This is the only time I have
ever used a PS/2 connection.

I can only assume it is something to do with whatever controller Cherry use
within the keyboards.

Is there any way I can solve this problem?

O/S is FreeBSD 9.0 RC1 amd64.  (I would leave this till running the final
production version except that the other Cherry keyboard would work with
the laptop running exact same O/S).  In case it matters, the motherboard is
a Abit - not sure of exact model but it is 2 or 3 years old.


freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to