On Mon, Apr 09, 2012 at 06:12:19PM +0200, Hans Petter Selasky wrote:

Hi Hans,

( Sorry for my lag to answer this email )

> On Friday 06 April 2012 23:50:07 Xavier wrote:
> > Hi to all,
> >
> > I attach an external USB Drive into a connector on the side of the
> > computer ( not USB hub ).
> >
> > DMESG(8) only say:
> >
> > ugen4.8: <Unknown> at usbus4 (disconnected)
> > uhub_reattach_port: could not allocate new device
> >
> > I'm running FreeBSD 9.0-RELEASE
> >
> > Can somebody help me ?
>
> Hi,
>
> Is your drive self powered?
>

Yes.

> Try also:
>
> sysctl hw.usb.ehci.no_hs=1
>

I try:

casa# sysctl hw.usb.ehci.no_hs
hw.usb.ehci.no_hs: 0
casa# sysctl hw.usb.ehci.no_hs=1
hw.usb.ehci.no_hs: 0 -> 1
casa# sysctl hw.usb.ehci.no_hs
hw.usb.ehci.no_hs: 1

Result:

ugen2.2: <LaCie> at usbus2
umass0: <LaCie LaCie DVDRW USB, class 0/0, rev 2.00/0.00, addr 2> on
usbus2
umass0:  8070i (ATAPI) over Bulk-Only; quirks = 0x0100
umass0:2:0:-1: Attached to scbus2
(probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
(probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(probe0:umass-sim0:0:0:0): SCSI status: Check Condition
(probe0:umass-sim0:0:0:0): SCSI sense: UNIT ATTENTION asc:29,0 (Power
on, reset,
 or bus device reset occurred)
 (probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
 (probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (probe0:umass-sim0:0:0:0): SCSI status: Check Condition
 (probe0:umass-sim0:0:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not
 present)
 (probe0:umass-sim0:0:0:0): Progress: 12% (8519/65536) complete
 cd1 at umass-sim0 bus 0 scbus2 target 0 lun 0
 cd1: <_NEC DVD_RW ND-3500AG 2.07> Removable CD-ROM SCSI-0 device
 cd1: 1.000MB/s transfers
 cd1: Attempt to query device size failed: NOT READY, Medium not present

# ls -l /dev/cd1*
crw-r-----  1 root  operator    0, 149 26 abr 17:49 /dev/cd1

In USB reader ins't any optical disc. Is correct the line "cd1: Attempt
to query device size failed: NOT READY, Medium not present" ?

If I unplug the USB connector, insert a blank CD-R in the unit and
plugin the USB connector I get:

ugen2.2: <LaCie> at usbus2
umass0: <LaCie LaCie DVDRW USB, class 0/0, rev 2.00/0.00, addr 2> on
usbus2
umass0:  8070i (ATAPI) over Bulk-Only; quirks = 0x0100
umass0:2:0:-1: Attached to scbus2
(probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
(probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(probe0:umass-sim0:0:0:0): SCSI status: Check Condition
(probe0:umass-sim0:0:0:0): SCSI sense: UNIT ATTENTION asc:29,0 (Power
on, reset,
 or bus device reset occurred)
 cd1 at umass-sim0 bus 0 scbus2 target 0 lun 0
 cd1: <_NEC DVD_RW ND-3500AG 2.07> Removable CD-ROM SCSI-0 device
 cd1: 1.000MB/s transfers
 cd1: cd present [1 x 2048 byte records]
 (cd1:umass-sim0:0:0:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0
 (cd1:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (cd1:umass-sim0:0:0:0): SCSI status: Check Condition
 (cd1:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal
 mode for t
 his track)
 (cd1:umass-sim0:0:0:0): cddone: got error 0x6 back
 (cd1:umass-sim0:0:0:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0
 (cd1:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (cd1:umass-sim0:0:0:0): SCSI status: Check Condition
 (cd1:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal
 mode for t
 his track)
 (cd1:umass-sim0:0:0:0): cddone: got error 0x6 back
 (cd1:umass-sim0:0:0:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0
 (cd1:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (cd1:umass-sim0:0:0:0): SCSI status: Check Condition
 (cd1:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal
 mode for t
 his track)
 (cd1:umass-sim0:0:0:0): cddone: got error 0x6 back
 (cd1:umass-sim0:0:0:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0
 (cd1:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (cd1:umass-sim0:0:0:0): SCSI status: Check Condition
 (cd1:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal
 mode for t
 his track)
 (cd1:umass-sim0:0:0:0): cddone: got error 0x6 back
 (cd1:umass-sim0:0:0:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0
 (cd1:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (cd1:umass-sim0:0:0:0): SCSI status: Check Condition
 (cd1:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal
 mode for t
 his track)
 (cd1:umass-sim0:0:0:0): cddone: got error 0x6 back
 (cd1:umass-sim0:0:0:0): READ(10). CDB: 28 0 0 0 0 0 0 0 1 0
 (cd1:umass-sim0:0:0:0): CAM status: SCSI Status Error
 (cd1:umass-sim0:0:0:0): SCSI status: Check Condition
 (cd1:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal
 mode for t
 his track)
 (cd1:umass-sim0:0:0:0): cddone: got error 0x6 back

If normal the output with a blank CD-R in the unit ?

Thanks, see you.
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to