>Number:         179342
>Category:       usb
>Synopsis:       Freebsd 10.0-current USB 3.0 not working (xhci_do_comand: 
>Command timeout!)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-usb
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Wed Jun 05 19:10:00 UTC 2013
>Closed-Date:
>Last-Modified:
>Originator:     Miguel C.
>Release:        
>Organization:
>Environment:
% uname -a
FreeBSD r2d2 10.0-CURRENT FreeBSD 10.0-CURRENT #0: Mon May 13 00:54:58 UTC 2013 
    r...@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
>Description:
This is an Ultrabook (acer s3) with only one USB 3.0 Controller (2-ports)

I first noticed that I could not install 10-current using the memstick images, 
I got stuck at mount root, after upgrading form 9.1 using base and kernel 
tarballs I noticed that the system has no longer detecting my memsticks.


When connecting usb devices (memstick,hdd) I get:

xhci_do_comand: Command timeout!
usb_alloc_device: device init 2 failed (USB_ERR_TIMEOUT, ignored)
usbgen0.2: <Unknown> at usbus0 (disconnected)
usb_reattach_port: could not allocate new device


More info about the controller:
xhci0: <Intel Panther Point USB 3.0 controller> mem 0xc0500000-0xc050ffff at 
device 20.0 on pci0

And has I explained in the mailling list, I already tried:

sysctl hw.xhci.xhci_port_route=-1 (and =1) in /boot/loader.conf 
(and in sysctl.conf but I guess the first one is the proper way

rebooted, and still no luck.


>How-To-Repeat:
1: Download a memstick image and dd to a usb, after boot you get stuck at 
"mountroot" prompt.

2: If you're able to install 10-0 current any other way, just connect a USB 
memstick to 3.0 controller, and you'll see the problem (unless if this is 
related to my controller specifically - Intel Panther Point USB 3.0)
>Fix:
Tried: sysctl hw.xhci.xhci_port_route=-1 -> DID NOT work!

>Release-Note:
>Audit-Trail:
>Unformatted:
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to