The kernel doesn't build with snd_uaudio.ko if there is sound.ko missing.

GENERIC kernel cannot load modules osscore.ko and oss_hdaudio.ko with
sound.ko either built in the kernel or loaded as a module. When I tried to
load snd_uaudio.ko manually, with both osscore.ko and oss_hdaudio.ko
loaded, exactly the same happened, as if I plugged in my camera.

I plugged in the camera after 50s of running (practically immediately after
boot). This is the kernel message on my monitor. I enabled dumpdev="AUTO"
in my /etc/rc.conf, to get the full output, but there was no file in
/var/log showing anything, so I just wrote here what I managed to see on
the screen:

(ada0:ata5:0:0:0): Error 5, Retries exahusted
(ada0:ata5:0:0:0): Synchronize cache failed
(ada1:ata5:0:1:0): FLUSHCACHE48. ACB: ea 00 00 00 00 40 00 00 00 00 00 00
(ada1:ata5:0:1:0): CAM status: CCB request is in progress
(ada1:ata5:0:1:0): Error 5, Retries exhausted
(ada1:ata5:0:1:0): Synchronize cache failed
Dumping 320 out of 3052 MB:kernel trap 12 with interrupts disabled


Fatal trap 12: page fault while in kernel mode
cpuid = 7; apic id = 07
fault virtual address        = 0x0
fault code                       = supervisor read data, page not present
instruction pointer          = 0x20:0xffffffff8028020c
stack pointer                  = 0x28:0xffffff80db5de890
frame pointer                 = 0x28:0xffffff80db5de940
code segment                = base 0x0, limit 0xfffff, type 0x1b
                                      = DPL 0, pres 1, long 1, def32 0,
gran 1
processor eflags             = resume, IOPL = 0
current process              = 1526 (kldload)
trap number                  = 12
panic: page fault
cpuid = 7
Uptime: 50s




2013/6/11 Jože Zobec <jozze.z...@gmail.com>

> Yes, I built without snd_uaudio.ko.
>
> In order to use the port audio/oss, I had to disable the sound.ko, so I
> had to exclude it from the kernel, and add it as a module.
>
> I agree, that snd_uaudio.ko brought improvements. I like it a lot. But
> snd_hda.ko, which I use to listen to music make those scratchy sounds all
> the time, where the music should be crystal clear.
>
> I will try now with the GENERIC kernel, and the kernel without sound.ko,
> and snd_hda.ko, but with snd_uaudio.ko enabled and see what will happen.
>
> Jože
>
>
> 2013/6/11 Hans Petter Selasky <h...@bitfrost.no>
>
>> On 06/10/13 22:39, Jože Zobec wrote:
>>
>>> Dear all,
>>>
>>> my name is Jože Zobec. I am using Logitech Webcam C525. So fare I have
>>> been
>>> able to use it flawlessly with drivers tat came with the base system.
>>> However, those same drivers fared rather poorly when I used them with
>>> audio/musicpd, so I tried to use audio/oss.
>>>
>>> So far so good. There has been a great improvement on the output quality
>>> given by musicpd, but my webcam doesn't work with these modules -- kernel
>>> automatically tries to create a /dev/dsp* device. To do that, it requires
>>> sound.ko module, which conflicts with module osscore.ko, supplied by the
>>> audio/oss port. Not knowing what to do, it starts to panic.
>>>
>>> Is there a way to use multimedia/webcamd with audio/oss, or is this
>>> unsupported? I am running FreeBSD 9.1-STABLE #3 r251600.
>>>
>>> Thank you for your time,
>>>
>>
>> Hi,
>>
>> Did you build a kernel without snd_uaudio?
>>
>> Also note that 9-stable has several USB audio improvements.
>>
>> --HPS
>>
>>
>
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to