On Tue, Dec 10, 2013 at 4:02 PM, Eitan Adler <li...@eitanadler.com> wrote:
> On Tue, Dec 10, 2013 at 3:44 PM, Hans Petter Selasky <h...@bitfrost.no> wrote:
>> On 12/10/13 21:23, Hans Petter Selasky wrote:
>>>
>>> On 12/10/13 21:16, Eitan Adler wrote:
>>>>
>>>> On Tue, Dec 10, 2013 at 2:16 PM, Hans Petter Selasky <h...@bitfrost.no>
>>>> wrote:
>>>>>
>>>>> On 12/10/13 19:47, Eitan Adler wrote:
>>>>>>
>>>>>>
>>>>>> [ moving back to the mailing list ]
>>>>>>
>>
>>>
>>> Looks like you traced the wrong endpoint. Should be endpoint 0x83. Could
>>> you check the other USB's ?
>>
>>
>> Sorry, it was the right endpoint after all, but I don't see any transfer
>> errors, so your device is working I assume.
>
> [ revision: FreeBSD gravity.local 11.0-CURRENT FreeBSD 11.0-CURRENT #6
> r259023: Mon Dec  9 22:22:57 EST 2013
> eitan@gravity.local:/usr/obj/usr/src/sys/EADLER  amd64 ]
>
> So far, yes, everything is working.  However, I've seen the errors
> above on this revision.  I'm not sure what is the exact reason for
> when I see them and when I don't.

After leaving the system running for a while I see:

[90548] uhub_reattach_port: could not allocate new device
[90549] usb_alloc_device: set address 2 failed (USB_ERR_IOERROR, ignored)
[90549] usbd_setup_device_desc: getting device descriptor at addr 2
failed, USB_ERR_IOERROR
[90549] usbd_req_re_enumerate: addr=2, set address failed!
(USB_ERR_IOERROR, ignored)
[90549] usbd_setup_device_desc: getting device descriptor at addr 2
failed, USB_ERR_IOERROR
[90550] usbd_req_re_enumerate: addr=2, set address failed!
(USB_ERR_IOERROR, ignored)
[90550] usbd_setup_device_desc: getting device descriptor at addr 2
failed, USB_ERR_IOERROR
[90550] usbd_req_re_enumerate: addr=2, set address failed!
(USB_ERR_IOERROR, ignored)
[90550] usbd_setup_device_desc: getting device descriptor at addr 2
failed, USB_ERR_IOERROR
[90552] usbd_req_re_enumerate: addr=2, set address failed!
(USB_ERR_IOERROR, ignored)
[90552] usbd_setup_device_desc: getting device descriptor at addr 2
failed, USB_ERR_IOERROR
[90552] ugen0.2: <Unknown> at usbus0 (disconnected)
[90552] uhub_reattach_port: could not allocate new device

I feel like there is something leaking but I'm not sure what.

-- 
Eitan Adler
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to