Something happened today, I'm not sure what, to make it impossible to attach my
USB hub to my 10.0-PRERELEASE machine


My full uname:
    FreeBSD kiwi 10.0-PRERELEASE FreeBSD 10.0-PRERELEASE #4 r259211: Wed Dec 11
    01:08:00 PST 2013     root@kiwi:/usr/obj/usr/src/sys/KIWI  amd64

When the issue originally happened, this was in the logs:

    Dec 16 10:30:42 kiwi kernel: ugen3.6: <samsung> at usbus3 (disconnected)
    Dec 16 11:02:30 kiwi kernel: ugen3.6: <samsung> at usbus3
    Dec 16 11:02:30 kiwi devd: Executing 'logger Unknown USB device: vendor 
0x04e8 product 0x685c bus uhub9'
    Dec 16 11:02:31 kiwi root: Unknown USB device: vendor 0x04e8 product 0x685c 
bus uhub9
    Dec 16 11:28:55 kiwi kernel: ugen3.2: <vendor 0x05e3> at usbus3 
(disconnected)
    Dec 16 11:28:55 kiwi kernel: uhub8: at uhub0, port 1, addr 2 (disconnected)
    Dec 16 11:28:55 kiwi kernel: ugen3.3: <vendor 0x05e3> at usbus3 
(disconnected)
    Dec 16 11:28:55 kiwi kernel: uhub9: at uhub8, port 1, addr 3 (disconnected)
    Dec 16 11:28:55 kiwi kernel: ugen3.6: <samsung> at usbus3 (disconnected)
    Dec 16 11:28:55 kiwi kernel: ugen3.4: <Microsoft> at usbus3 (disconnected)
    Dec 16 11:28:55 kiwi kernel: ukbd0: at uhub9, port 2, addr 4 (disconnected)
    Dec 16 11:28:55 kiwi kernel: uhid0: at uhub9, port 2, addr 4 (disconnected)
    Dec 16 11:28:55 kiwi devd: Executing '/etc/rc.d/syscons setkeyboard 
/dev/kbd0'
    Dec 16 11:28:55 kiwi kernel: ugen3.5: <Dell> at usbus3 (disconnected)
    Dec 16 11:28:55 kiwi kernel: ums0: at uhub8, port 4, addr 5 (disconnected)
    Dec 16 11:28:55 kiwi devd: Executing '/etc/rc.d/moused stop ums0'
    Dec 16 11:29:01 kiwi kernel: usb_alloc_device: set address 2 failed 
(USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:06 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:08 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:13 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:15 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:21 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:22 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:28 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:29 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:35 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:35 kiwi kernel: ugen3.2: <Unknown> at usbus3 (disconnected)
    Dec 16 11:29:35 kiwi kernel: uhub_reattach_port: could not allocate new 
device
    Dec 16 11:29:37 kiwi kernel: usb_alloc_device: set address 2 failed 
(USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:42 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:44 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:49 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:51 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:29:56 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:29:58 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:30:03 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:30:05 kiwi kernel: usbd_req_re_enumerate: addr=2, set address 
failed! (USB_ERR_TIMEOUT, ignored)
    Dec 16 11:30:10 kiwi kernel: usbd_setup_device_desc: getting device 
descriptor at addr 2 failed, USB_ERR_TIMEOUT
    Dec 16 11:30:10 kiwi kernel: ugen3.2: <Unknown> at usbus3 (disconnected)
    Dec 16 11:30:11 kiwi kernel: uhub_reattach_port: could not allocate new 
device


I enabled some debugging based on an earlier conversation on this list, and
connected the hub again, see that more full log here: 
<https://gist.github.com/rtyler/7995656>


I should note that I'm able to attach the individual devices on the hub to the
same USB port without issue.



Cheers
- R. Tyler Croy
------------------
   Code: https://github.com/rtyler
Chatter: https://twitter.com/agentdero
         rty...@jabber.org

Attachment: pgpeHsCHZ1NGh.pgp
Description: PGP signature

Reply via email to