The following reply was made to PR usb/185628; it has been noted by GNATS.

From: Alex Goncharov <alex_goncharov_...@yahoo.com>
To: Hans Petter Selasky <h...@bitfrost.no>,
  "freebsd-gnats-sub...@freebsd.org" <freebsd-gnats-sub...@freebsd.org>
Cc:  
Subject: Re: usb/185628: usbd_req_re_enumerate set address failed 
USB_ERR_STALLED for Seagate USB drives between r259425 and r260321
Date: Fri, 10 Jan 2014 19:50:58 -0800 (PST)

 --464114708-874558429-1389412258=:8299
 Content-Type: text/plain; charset=iso-8859-1
 Content-Transfer-Encoding: quoted-printable
 
 I rebuilt the kernel with change 259722 reverted:=0A=0A=A0 ident /boot/kern=
 el.scsi_all-back/kernel | grep /scsi_all.c=0A=A0 =3D>=0A=A0=A0=A0=A0 $FreeB=
 SD: stable/9/sys/cam/scsi/scsi_all.c 257050 2013-10-24 10:34:13Z mav $=0A=
 =0AStill have the same dmesges:=0A=0A-----=0Ausbd_req_re_enumerate: addr=3D=
 2, set address failed! (USB_ERR_STALLED, ignored)=0Ausbd_setup_device_desc:=
  getting device descriptor at addr 2 failed, USB_ERR_STALLED=0Ausbd_req_re_=
 enumerate: addr=3D2, set address failed! (USB_ERR_STALLED, ignored)=0Ausbd_=
 setup_device_desc: getting device descriptor at addr 2 failed, USB_ERR_STAL=
 LED=0Ausb_alloc_device: Failure selecting configuration index 0:USB_ERR_STA=
 LLED, port 4, addr 2 (ignored)=0Augen5.2: <Seagate> at usbus5=0A----=0A=0AI=
 'll launch another rebuild for the night, after 'svn up' -- maybe something=
  will be discovered.=A0 If anybody has suggestions on debugging the issue, =
 please let me know.=0A=0A-- Alex=0A=0A=0A=0A=0AOn Friday, January 10, 2014 =
 8:08 AM, Hans Petter Selasky <h...@bitfrost.no> wrote:=0A =0AOn 01/10/14 12:=
 49, Alex Goncharov wrote:=0A>> >If devices simply re-attach either they are=
  not respond and software=0A>> >initiates a reset, which can be disabled by=
  setting=0A>> >"hw.usb.no_cs_fail" or the software in the USB HDD died and=
 =0A>> >rebooted.=0A> May be; but think about the fact correlations: the fac=
 t of the two=0A> system's upgrade, two identical Seagate units, and other H=
 DDs being=0A> non-stalled.=0A>=0A=0AHi,=0A=0AIf you are running EHCI, there=
  has been no changes in the USB stack, and =0Ayou should look for CAM/SCSI =
 related changes:=0A=0AJust grepping quickly, can this be related to what yo=
 u are seeing?=0A=0Ahttp://svnweb.freebsd.org/changeset/base/259722=0A=0A--H=
 PS
 --464114708-874558429-1389412258=:8299
 Content-Type: text/html; charset=iso-8859-1
 Content-Transfer-Encoding: quoted-printable
 
 <html><body><div style=3D"color:#000; background-color:#fff; font-family:He=
 lveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif;fo=
 nt-size:12pt">I rebuilt the kernel with change 259722 reve<span class=3D"ta=
 b">rted:<br><br>&nbsp; ident /boot/kernel.scsi_all-back/kernel | grep /scsi=
 _all.c<br>&nbsp; =3D&gt;<br>&nbsp;&nbsp;&nbsp;&nbsp; $FreeBSD: stable/9/sys=
 /cam/scsi/scsi_all.c 257050 2013-10-24 10:34:13Z mav $<br><br>Still have th=
 e same dmesges:<br><br>-----<br>usbd_req_re_enumerate: addr=3D2, set addres=
 s failed! (USB_ERR_STALLED, ignored)<br>usbd_setup_device_desc: getting dev=
 ice descriptor at addr 2 failed, USB_ERR_STALLED<br>usbd_req_re_enumerate: =
 addr=3D2, set address failed! (USB_ERR_STALLED, ignored)<br>usbd_setup_devi=
 ce_desc: getting device descriptor at addr 2 failed, USB_ERR_STALLED<br>usb=
 _alloc_device: Failure selecting configuration index 0:USB_ERR_STALLED, por=
 t 4, addr 2 (ignored)<br>ugen5.2: &lt;Seagate&gt; at
  usbus5<br>----<br><br>I'll launch another rebuild for the night, after 'sv=
 n up' -- maybe something will be discovered.&nbsp; If anybody has suggestio=
 ns on debugging the issue, please let me know.<br><br>-- Alex<br><span clas=
 s=3D"tab"></span></span><div style=3D"display: block;" class=3D"yahoo_quote=
 d"> <br> <br> <div style=3D"font-family: HelveticaNeue, Helvetica Neue, Hel=
 vetica, Arial, Lucida Grande, sans-serif; font-size: 12pt;"> <div style=3D"=
 font-family: HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande=
 , sans-serif; font-size: 12pt;"> <div dir=3D"ltr"> <font face=3D"Arial" siz=
 e=3D"2"> On Friday, January 10, 2014 8:08 AM, Hans Petter Selasky &lt;hps@b=
 itfrost.no&gt; wrote:<br> </font> </div>  <div class=3D"y_msg_container">On=
  01/10/14 12:49, Alex Goncharov wrote:<br>&gt;&gt; &gt;If devices simply re=
 -attach either they are not respond and software<br>&gt;&gt; &gt;initiates =
 a reset, which can be disabled by setting<br>&gt;&gt; &gt;"hw.usb.no_cs_fai=
 l" or the
  software in the USB HDD died and<br>&gt;&gt; &gt;rebooted.<br>&gt; May be;=
  but think about the fact correlations: the fact of the two<br>&gt; system'=
 s upgrade, two identical Seagate units, and other HDDs being<br>&gt; non-st=
 alled.<br>&gt;<br><br>Hi,<br><br>If you are running EHCI, there has been no=
  changes in the USB stack, and <br>you should look for CAM/SCSI related cha=
 nges:<br><br>Just grepping quickly, can this be related to what you are see=
 ing?<br><br><a href=3D"http://svnweb.freebsd.org/changeset/base/259722"; tar=
 get=3D"_blank">http://svnweb.freebsd.org/changeset/base/259722</a><br><br>-=
 -HPS<br><br><br></div>  </div> </div>  </div> </div></body></html>
 --464114708-874558429-1389412258=:8299--
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to