The following reply was made to PR usb/186110; it has been noted by GNATS.

From: Hans Petter Selasky <>
To: Volker Nebel <>,
Subject: Re: usb/186110: connected over USB, only first document is printed
Date: Sat, 25 Jan 2014 23:46:38 +0100

 On 01/25/14 22:35, Volker Nebel wrote:
 >> Number:         186110
 >> Category:       usb
 >> Synopsis:       connected over USB, only first document is printed
 >> Confidential:   no
 >> Severity:       non-critical
 >> Priority:       low
 >> Responsible:    freebsd-usb
 >> State:          open
 >> Quarter:
 >> Keywords:
 >> Date-Required:
 >> Class:          sw-bug
 >> Submitter-Id:   current-users
 >> Arrival-Date:   Sat Jan 25 21:40:00 UTC 2014
 >> Closed-Date:
 >> Last-Modified:
 >> Originator:     Volker Nebel
 >> Release:        10.0 on a Macmini, 8.0 on an Acer laptop
 >> Organization:
 >> Environment:
 > FreeBSD 10.0-RELEASE FreeBSD 10.0-Release #1: Fri Jan 24 
 > 20:32:29
 >   CET 2014  amd64
 > and for the ACER lapopt:
 > FreeBSD 8.0-RELEASE FreeBSD 8.0-RELEASE #3: Sat Jan 30 10:46:59 
 > CET
 >   2010  i386
 >> Description:
 > Hi!
 > Perhaps I only fail because the handbook (which is excellent in many ways) 
 > provi
 > des only little info on how to connect a printer to an USB port. In case 
 > there i
 > s something special I overlooked, please let me know how I should do it and 
 > send
 >   this PR to Class www.
 >     My printer is an HP LaserJet 6MP without an USB interface (too old). It 
 > serve
 > s me fine when connected to a computer's parallel port. When I connect this 
 > prin
 > ter to a computer's USB port (with an adapter cable), only the first 
 > document (w
 > hat size ever) is printed. For further documents, printer starts blinking, 
 > stops
 >   blinking and does nothing.
 >     For modern computers no longer have a parallel port, I can only connect 
 > via U
 > SB.
 >     Obviously, the problem has nothing to with the spooling system, for it 
 > happen
 > s as well with [CMD=" "]cat > /dev/ulpt0[/CMD] issued twice: The 
 > first d
 > ocument is printed, any further not. (The printer understands Postscript.) 
 > Same
 > situation with /dev/unlpt0.
 >     I observe(d) the problem
 > - on my Acer Laptop with FreeBSD 8.0 (after [CMD=" "]kldload ulpt[/CMD])
 > - on my Apple Macmini with FreeBSD 10.0 (where ulpt is compiled into the 
 > kernel)
 > - on a laptop I had in the meantime of which I remember nothing except 
 > having Fr
 > eebSD installed
 > - on my Apple Macmini running under XUbuntu 10.4.3
 >     I do/did not observe the problem
 > + on my Apple Macmini running under MacOS X MountainLeopard (which I have 
 > completely replaced by FreeBSD)
 > + on my Acer Laptop using parallel port.
 >     Surprisingly the problem cannot be solved by turning the printer off and 
 > on a
 > gain. It can be solved by rebooting the computer (leaving the printer on).
 >     When I issue [CMD=" "]lpr[/CMD] a 2nd time and [CMD=" 
 > "]lpq[/CMD], I
 > get:
 > "waiting for lp to become ready (offline?)"
 >      When connected to the parallel interface interface, the printer worked 
 > fine
 > only in "polled mode". Unfortunately, I don't know how to tune 
 > /boot/device.hint
 > s for ulpt. And [CMD=" "]lptcontrol -p -d /dev/ulpt0[/CMD] returns: 
 > "lptcontrol:
 >   ioctl: Operation not supported by device".
 > Best regards,
 > Volker
 You can trace the USB traffic using usbdump. man usbdump Maybe that will 
 give you the clues you need to find the problem.
 Thank you!
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to