The following reply was made to PR usb/187188; it has been noted by GNATS.

From: =?ISO-2022-JP?B?SGlyb28gT25vICgbJEI+LkxuNDJAOBsoQik=?= 
To: Hans Petter Selasky <>
Subject: Re: usb/187188: [USB][patch] ELECOM WRH-150 needs a quirk
Date: Tue, 4 Mar 2014 21:15:42 +0900

 I have tried with stable r262711, and it is recognized as umodem0,
 same as with 10.0R.
 ugen4.3: <ELECOM CO., LTD.> at usbus4
 umodem0: <RNDIS COmmunications Control> on usbus4
 umodem0: data interface 1, has no CM over data, has no break
 This device is a NAT router, which has a (wired) ethernet interface
 for the WAN side.
 For the LAN side, it has a wireless interface and a USB interface.
 The USB interface has 2 configuration indexes.
 The config index 0 is recognized as umodem0, and config index 1 is
 recognized as ue0.
 For the usual case, I want it to be recognized as ue, which need a
 quirk to set the
 config index to 1.
 The user manual of this device says that, when I plug in the device to
 windows PC,
 the driver installation starts, and then it is recognized as an USB
 ethernet device.
 So, similar setting should be used for Windows.
 I do not know what the umodem of config index 0 is for. hrs@ who suggested me 
 use the quirk speculated that it might be used to update the firmware,
 but not sure.
 2014-03-03 17:16 GMT+09:00 Hans Petter Selasky <>:
 > If you upgrade to -stable there should be an RNDIS driver in FreeBSD now.
 > Have you tried that:
 > /boot/kernel/if_urndis.ko
 > --HPS
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to