On 12/07/14 23:52, Torfinn Ingolfsen wrote:
Question: is writing to the device file (/dev/ugenX) with normal file calls 
supposed to work in FreeBSD?
(as in "everything is a file" in unix-like operating systems)

Background: I recently got a usb label printer for cheap: a Dymo LabelManager 
PnP[1]. I found the dymoprint[2] Python script, which works fairly well on 
It works (AFAICT) by reading / writing the usb device as a regular file, via 
the device file.
You have to use usb_modeswitch[3] on the printer first, of course.


/dev/ugenX is not a stream. You should either consider using libusb or /dev/ulptX .

If it is supposed to work with those devices, you should postfix the endpoint number:



Since we have all tools available on FreeBSD, I tried the setup on my FreeBSD 
workstation, which currently runs FreeBSD 9.3-stable:
tingo@kg-core1$ uname -a
FreeBSD kg-core1.kg4.no 9.3-STABLE FreeBSD 9.3-STABLE #0 r273918: Fri Oct 31 
22:52:44 CET 2014     r...@kg-core1.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64

The detection code in the dymoprint script doesn't work on FreeBSD, but setting 
the correct device via DEV_NODE in the script works:
tingo@kg-core1$ grep ^DEV_NODE dymoprint2
DEV_NODE       = "/dev/ugen3.4"

But when I run the script I just get an IO error:
root@kg-core1# python dymoprint2 test
Traceback (most recent call last):
   File "dymoprint2", line 313, in <module>
   File "dymoprint2", line 309, in main
     lm.printLabel(labelmatrix, dottab)
   File "dymoprint2", line 183, in printLabel
     response = self.sendCommand()
   File "dymoprint2", line 80, in sendCommand
     responseBin = self.dev.read(8)
IOError: [Errno 5] Input/output error

1) http://global.dymo.com/ieIE/Products/LabelManager_PnP.html
2) http://sbronner.com/dymoprint/
3) http://www.draisberghof.de/usb_modeswitch/

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to