Bug ID: 198647
           Summary: MX-ES USB Drive by Mach Xtreme ILLEGAL REQUEST
                    asc:21,0 (Logical block address out of range)
           Product: Base System
           Version: 11.0-CURRENT
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: usb

I am trying to install FreeBSD 9.3, also tried 10.1 and 11.0, to an mx-ex 8gb
flash drive. Here is a link to the specifications:
It is a usb3 device, but plugged into usb2 ports.

If I go to the shell and unplug the device then plug it back in here are the
errors I get (partial, some scroll off screen):
[CODE](da0:umass-sim0:0:0:0): Error 22, Unretryable error
(da0:umass-sim0:0:0:0): Read(10). CDB: 28 00 00 ee 4f ff 00 00 01 00
(da0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(da0:umass-sim0:0:0:0): SCSI status Check Condition
(da0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:21,0 (Logical block
address out of range)
and then it repeats the same error, I think I saw some flash by that said
Write() instead of Read(10) during one of my attempts.

I have tried reinitializing the disk using windows disk manager which seemed to
work fine. Drive behaves as expected in my windows machines and linux CentOS.
This has happened both on a Dell R610 and a HP touchsmart tx2 laptop.  The dell
R610 works with FreeBSD except for this memory stick.

If I drop to shell during installation I can get the following information:
[CODE]camcontrol inquiry da1:
pass3: <MX MXUB3SES-8GB 1.00> Removable Direct Access SCSI-6 device
pass3: Serial Number 000000000000000133
pass3: 40.000MB/s transfers

dmesg | grep ^da1
da1: at umass-sim1 bus 1 scbus 4 target 0 lun 0
da1: <MX MXUB3SES-8GB 1.00> Removable Direct Access SCSI-6 device
da1: Serial Number 000000000000000133
da1: 40.000MB/s transfers
da1: 7626MB (15618048 512 byte secotrs: 255H 63S/T 972C)
da1: quirks=0x2<NO_6_BYTE>
Seems similar, but different to bug 194062

If from shell before trying to install I do a [CMD]sysctl[/CMD] then I am able to get farther showing
the "please review the disk setup" screen, and instead of giving read errors it
gives the following error after hitting commit:
[CODE]write(16). cdb: 8a 00 00 00 00 00 00 00 00 00 00 00 00 01 00 00
cam status: ccb request completed with an error
error 5, retries exhausted[/CODE]

You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to