On Sat, Jul 18, 2015 at 11:24 PM, Hans Petter Selasky <h...@selasky.org> wrote:
> On 07/17/15 21:28, Tom Lislegaard wrote:
>> This is an RPI2 with a recent CURRENT snapshot, but the original RPI with
>> 10.1-Stable give exactly the same result. The camera works without
>> problems
>> on amd64 with 10.1-Stable.
>> tl@rpi2:~ % uname -a
>> FreeBSD rpi2 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r284969: Wed Jul  8
>> 19:50:02 CEST 2015     tl@rpi2:/usr/obj/usr/src/sys/RPI2  arm
>> Trying to connect the camera I get this error
>> usb_alloc_device: Failure selecting configuration index 0:USB_ERR_TIMEOUT,
>> port 4, addr 5 (ignored)
>> Things I have tried include disconnecting all other usb-devices, and
>> connect the cam via an external powered hub.
>> usbconfig/lsusb show the following
> If you run:
> usbconfig -d X.Y set_config 0
> Does it work?

set_config 0 does not help. No errors messages, but usbconfig still
report "cfg=255" for the device

> Have you tried other webcams? Might be a timing issue at USB transaction
> level, because the USB controller in the RPI is driven mostly by software,
> while on the PC side by hardware.

I tried a different Logitech (very old, reported as model "Quickcam E
3500") which is recognized fine

> If you update the RPI2 kernel to the latest as of today - any difference?

I've updated to CURRENT revision r285693M. It did not help as I get
exactly the same error.

> My Logitech webcam enumerates just fine.

Is this a current model?
I may look at an alternative to the C525, but unfortunately the E3500
is truly a piece of crap and inadequate for my intended use. My
requirement is reasonable quality stills, streaming video is not


> --HPS
freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to