On Tue, 22 Mar 2016, Warren Block wrote:

This Realtek RTS5401 USB 3.0 hub is combined in a case with three USB 3.0 ports and a Realtek RTL8153 Gigabit Ethernet adapter.


Connected to a USB 2.0 port, it shows this:

 ugen1.3: <Realtek> at usbus1
 uhub4: <Realtek USB3.0 Hub, class 9/0, rev 2.10/1.11, addr 3> on usbus1
 uhub4: MTT could not be enabled
 device_attach: uhub4 attach returned 6

I have not tried it on a USB 3.0 port yet.

It would not really bother me if only the Ethernet worked, but surely it is connected to the hub, so will be all or nothing. Any suggestions?

On a USB 3.0 port on a -CURRENT system (r297315), the hub is recognized and works:

  ugen 0.2: <Realtek> at usbus0
  uhub1: <Realtek USB3.0 Hub, class 9/0, rev 2.10/1.11, addr 10> on usbus0
  uhub1: MTT could not be enabled
  device_attach: uhub1 attach returned 6
  ugen0.3: <Realtek> at usbus0
  uhub1: <Interrupt In Interface> on usbus0
  uhub1: 4 ports with 4 removable, self powered

Are USB 3 hubs not backwards compatible? Maybe just this one specifically? USB 2.0 devices like mice are not recognized when attached. A USB 3.0 memory stick is recognized.

The attached Ethernet port is still not seen. Should rue(4) support the RTL8153?
_______________________________________________
freebsd-usb@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to