Tue, 30 Aug 2016 21:33:28 +0300 було написано Otacílio <otacilio.n...@bsd.com.br>:

I have no ideas here (it works (mostly) fine on x86 and I have no possibility
to check it with ARM).

P.S. Other (ARM-specific?) issues:
https://lists.freebsd.org/pipermail/freebsd-arm/2016-July/014382.html
https://forums.freebsd.org/threads/57396


Dears

I'm using a beaglebone black to stream video over UDP. I wrote a software and have tested it using a urtwn device + webcam Logitech C920. All is connected using a USB hub with external power source. So urtwn and webcam, both are plugged in the same USB hub. When I plug the hub and run my software on a old notebook intel centrino with FreeBSD 11.0-RC2 AMD64 all works fine. Last night the system stream video all night. But, when I replace the notebook by beaglebone black running FreeBSD 11.0-RC1 with the same USB HUB, the same wrtwn device and same camera, randomly after some time the beaglebone black network shutdown and terminal shows this messages :


Network is down
% urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.
urtwn0: ieee80211_crypto_encap returns NULL.

Then, I need to run

/etc/rc.d/netif stop

/etc/rc.d/netif start

To enable network again. So, someone can give me a hit about what can be this and how to fix?

Thanks a lot

[]'s

-Otacilio

_______________________________________________
freebsd-wirel...@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"
_______________________________________________
freebsd-usb@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to