Greetings,

I've asked in the past why FreeBSD seems to have such problems with
USB3 devices and controllers, in particular, and various people of
good will and admirable patience have been kind enough to explain
to me the difficulties of trying to write drivers for things where
nobody actually follows the standards, however...

Just a day or two ago I downloaded the file:

    FreeBSD-10.3-RELEASE-amd64-memstick.img

and then dd'ed it to a recent vintage Sandisk Flair USB 3.0 16GB stick,
stuck that into one of the built-in USB 3 sockets on my Asus A78M-A and
tried to boot so I could do a fresh install of 10.3-RELEASE.

Long story short, after getting past most of the boot up process, the
install that I had hoped to do crashed and burned.  The first irrecoverable
error message seemed to be this one:

  Mounting from ufs:/dev/ufs/FreeBSD_Install failed with error 19.

(Of course, I have no idea what "error 19" is.  Is that ENODEV?)

Anyway, I at least had the good sense to try again with the same USB
stick, but this time with the thing plugged into one of the built-in
USB 2 ports on the motherboard.

That, worked, no problem, and I was able to complete the install.

But this series of events leaves me worrying.  In the past, I've had
literally a ton of trouble getting anything USB3-ish to work reliably,
ever, with FreeBSD.  But the last time I even tried was a couple of
years ago.  I had sort-of vaguely hoped that things might have matured
since then, and that at least there would be good support by now for
common and widely used motherboard chipsets (in this case, AMD A78 FCH,
Bolton D3) as well as widely used devices such as recent vintage Sandisk 
USB3 sticks.  But as noted above, I was unable to even perform a simple
install using this combination.  And it wasn't like I was trying to
install something ancient and crusty.  I was trying to install 10.3-RELEASE.

So, questions:

   1) Where can I find a list of which USB3 chipsets are in fact supported
   by, for example, 10.3-RELEASE? 
   
   2) Where can I find a list of which USB3 devices are in fact supported
   by, for example, 10.3-RELEASE? 
   
   3)  Why did my install crash and burn, and what the bleep is error 19?
       (If that signifies ENODEV in this context, then, I mean, what the
       bleep?  Why would a UFS mount work fine when a given device is plugged
       into a USB2 port but _not_ when it is plugged into a USB3 port?)

   4)  Should I assume that the USB3 ports on my Asus A78M-A won't be
       working any more reliably _after_ the install of 10.3 than they
       appear to have done _during_ the install?


Regards,
rfg
_______________________________________________
freebsd-usb@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to