伊藤です。

>  tip を終了して ttys を 3wire を使って書き換えて

一度だけ login: とでましたが、ユーザ名入力後にEnter押すも
反応なしでした。

コマンドの実行結果は下記となります。

# grep ^uart /var/run/dmesg.boot
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0

# ps awl | grep getty
   0 1098    1   0  52  0 10124 1748 ttyin  Is+  v0  0:00.00 /usr/libexec/getty 
Pc ttyv0
   0 1099    1   0  52  0 10124 1748 ttyin  Is+  v1  0:00.00 /usr/libexec/getty 
Pc ttyv1
   0 1100    1   0  52  0 10124 1748 ttyin  Is+  v2  0:00.00 /usr/libexec/getty 
Pc ttyv2
   0 1101    1   0  52  0 10124 1748 ttyin  Is+  v3  0:00.00 /usr/libexec/getty 
Pc ttyv3
   0 1102    1   0  52  0 10124 1748 ttyin  Is+  v4  0:00.00 /usr/libexec/getty 
Pc ttyv4
   0 1103    1   0  52  0 10124 1748 ttyin  Is+  v5  0:00.00 /usr/libexec/getty 
Pc ttyv5
   0 1104    1   0  52  0 10124 1748 ttyin  Is+  v6  0:00.00 /usr/libexec/getty 
Pc ttyv6
   0 1105    1   0  52  0 10124 1748 ttyin  Is+  v7  0:00.00 /usr/libexec/getty 
Pc ttyv7

# conscontrol list
Configured: ttyv0
 Available: ttyv0,uart,ttyv0
    Muting: off

また、hint.uart.0.flags="0x110"を追加したところ、
tip com1を実行すると link down となり通信不可でした。

その後、loader.confのhint.uart.0.flags="0x110"を消して、
tip com1を実行しても下記のようになるようになりました。

/dev/cuau0: Device busy
link down

以上です。

On Mon, 24 Nov 2014 11:29:40 +0900 (JST)
Hiroki Sato <h...@freebsd.org> wrote:

> Tetsuya Ito <chalt...@agate.plala.or.jp> wrote
>   in <20141124003527.0882.a7d5a...@agate.plala.or.jp>:
> 
> ch> ご連絡ありがとうございます。
> ch>
> ch> 早速試してみましたがログインプロンプトはでませんでした。
> 
>  これは出なくて正しいです。
>  接続中は tip が ttyu0 を使用しているので
>  ログインプロンプトを出すことができません。
> 
>  tip を終了して ttys を 3wire を使って書き換えて
>  kill -HUP 1 すれば出るはずですが、本当に出ないとすると
>  設定の問題ではなく、ハードウェアの挙動がおかしいことになります。
> 
>  次の 3 つのコマンドの出力を送っていただくことは
>  可能でしょうか?
> 
>  % grep ^uart /var/run/dmesg.boot
> 
>  % ps awl | grep getty
> 
>  % conscontrol list
> 
>  また、loader.conf に
> 
>  hint.uart.0.flags="0x110"
> 
>  という行を追加して再起動した場合、挙動は変化するでしょうか?
> 
> ch> shutdown -r now の挙動が変だったり、この辺りの変更が
> ch> 10.1Rで行われていて、その影響なのでしょうかね...。
> ch> 10.0Rの時に試していないのが悔やまれます...。
> 
>  コードは何も変わっていませんが、以前は使えていたのでしょうか?
> 
> -- Hiroki

_______________________________________________
freebsd-users-jp@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-users-jp
To unsubscribe, send any mail to "freebsd-users-jp-unsubscr...@freebsd.org"

メールによる返信