こんばんは。宮尾です。

FreeBSD10.1Rにアップグレードするとzfsがうまくマウントできない現象に遭
遇しましたので報告します。

1台はfreebsd-updateでアップグレードしてリブートをかけました。
そうすると/homeにマウントしていたzfsのファイルシステムが見えなくなりま
した。
zpool statusでFAILになっていたので、あきらめていたのですか、翌日見ると
% zpool status
  pool: home
 state: ONLINE
status: One or more devices has experienced an error resulting in data
        corruption.  Applications may be affected.
action: Restore the file in question if possible.  Otherwise restore
the
        entire pool from backup.
   see: http://illumos.org/msg/ZFS-8000-8A
  scan: none requested
config:

        NAME                      STATE     READ WRITE CKSUM
        home                      ONLINE       0     0 4.11M
          diskid/DISK-9CAAE6AB01  ONLINE       0     0 16.7M

errors: 100298 data errors, use '-v' for a list
と激しく壊れているようです。homeはAdaptecのRAID6405のディスクでプール
を作っていました。

10.1Rでのdmesgは
aacraid0: <Adaptec RAID Controller> mem
0xfa800000-0xfabfffff,0xfa7bc000-0xfa7bc
7ff,0xfa7be000-0xfa7be0ff irq 30 at device 0.0 on pci4
aacraid0: Enable Raw I/O
aacraid0: Enable 64-bit array
aacraid0: New comm. interface type1 enabled
aacraid0: Adaptec 6405, aacraid driver 3.2.5-1
aacraidp0 on aacraid0
aacraidp1 on aacraid0
aacraidp2 on aacraid0
aacraidp3 on aacraid0
略
ses0 at aacraidp3 bus 0 scbus3 target 0 lun 0
ses0: <ADAPTEC Virtual SGPIO \134000\134000\134000?> Fixed Enclosure
Services SC
SI-5 device
pass3: Serial Number       JK11D1BEGEHSPZ
pass3: 300.000MB/s transfers
pass3: Command Queueing enabled
pass4 at aacraidp1 bus 0 scbus1 target 2 lun 0
pass4: <Hitachi HUA722020ALA330 JKAO> Fixed unknown SCSI-5 device
(offline)
pass4: Serial Number       JK11E1BFG7T2HT
pass4: 300.000MB/s transfers
da0 at aacraidp0 bus 0 scbus0 target 0 lun 0
da1 at aacraidp0 bus 0 scbus0 target 1 lun 0
da0: <Adaptec Array V1.0> Fixed Direct Access SCSI-4 device
da0: Serial Number B992E6AB00
da0: 300.000MB/s transfers
da0: Command Queueing enabled
da0: 1904630MB (3900682240 512 byte sectors: 255H 63S/T 242806C)
cd0 at ata4 bus 0 scbus6 target 0 lun 0
cd0: <TEAC DV-28S-W 1.2B> Removable CD-ROM SCSI-0 device
cd0: Serial Number 10111204074530
cd0: 150.000MB/s transfers (SATA 1.x, UDMA5, ATAPI 12bytes, PIO
8192bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not
present - tray c
losed
da1: <Adaptec Array V1.0> Fixed Direct Access SCSI-4 device
da1: Serial Number 9CAAE6AB01
da1: 300.000MB/s transfers
da1: Command Queueing enabled
da1: 1904630MB (3900682240 512 byte sectors: 255H 63S/T 242806C)
です。

freebsd-updateでの更新が悪かったのかと思って、もう1台はソースからコン
パイルして入れてみましたが、同じ症状が再発しました。おそらく、raid(ミ
ラー)の片側のディスクのみを認識してマウントしているようです。
10.0までは、このようなことはありませんでした。現在は別マシンのスナップ
ショットより戻しているところです。
一旦destroyして、poolをcreateすると以前のように/dev/da1を認識してpool
ができました。おそらく起動時のディスクの認識の順番に問題があるのではな
いかと思います。

以上、報告させていただきます。

宮尾安藝雄


_______________________________________________
freebsd-users-jp@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-users-jp
To unsubscribe, send any mail to "freebsd-users-jp-unsubscr...@freebsd.org"

メールによる返信