統計数理研究所の丸山です。

FreeBSD7.4までは firefoxで Adobe flashplayerを動かすことは私もできていた
のですが、FreeBSD9.x, 10.x では Adobe flashflayer は使えないものと長い間
思い込んでいました(8.xは使ったことなし)。それが、昨日次の現象に出会い、
何か変だと気が付きました。

Suica Point Club のサイト http://www.jreast.co.jp/suicapoint/index.html
にFirefoxでアクセスする場合と Google Chrome でアクセスする場合に大きな違
いがあることを発見し、 flashplayer がFirefox上では動き、Chromeでは動いて
いないことを確信しました。

環境は

PCBSD10.2 (FreeBSD 10.2-RELEASE-p11)
firefox-40.0.3,1
chromium-47.0.2526.73
linux-c6-flashplugin-11.2r202.508
nspluginwrapper-1.4.4_4

いずれのパッケージもただ pkg add しただけで、特に何もいじっていません。
PCBSDではインストール時に

  /usr/local/bin/flashpluginctl on

というコマンドをすべてのユーザについて実行するのですが、中身を見ると要す
るに

  nspluginwrapper -i  
/usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so

ということです。試しに確認すると

[maruyama@pc01{56}] ~% nspluginwrapper -l
/usr/local/lib/browser_plugins/npwrapper.libflashplayer.so
  Original plugin:
  /usr/local/lib/browser_plugins/linux-c6-flashplugin/libflashplayer.so
  Plugin viewer: /usr/local/lib/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.4.4-1
/usr/home/maruyama/.mozilla/plugins/npwrapper.libflashplayer.so
  Original plugin:
  /usr/local/lib/browser_plugins/symlinks/linux-firefox/libflashplayer.so
  Plugin viewer: /usr/local/lib/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.4.4-1

となります。 chrome の about:plugins では Chromium PDF Viewer が二つ表示
されるだけです。

以上のことから、 FreeBSD handbook 6.2節

https://www.freebsd.org/doc/ja_JP.eucJP/books/handbook/desktop-browsers.htm
https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-browsers.html

は全く実状に合っていないと断言せざるを得ませんが、さてここで質問です。
Chromeで Adobe flashplayer を使うにはどうしたら良いのでしょうか。

--------
丸山直昌@統計数理研究所
_______________________________________________
freebsd-users-jp@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-users-jp
To unsubscribe, send any mail to "freebsd-users-jp-unsubscr...@freebsd.org"

メールによる返信