悸村さん、辰己さん
  青木です

結論として直りました。
ありがとうございます。

主に悸村木村さんの助言が役にたちました。

ports/UPDATINGが出ていたんですね。見落としていました。(※)

どれが主に効いていたのかはよく分かりませんが、以下の手順で回復しました。
  https://www.freebsd.org/doc/ja_JP.eucJP/books/handbook/x-config.html
を見て、rc.confに
kld_list="i915kms.ko"
を追加し、念のため再起動。
#dbusは従来通り起動しています。haldはもともと起動していません。

/etc/X11/xorg.confをrename、また、
  /usr/local/etc/X11/xorg.conf.d/driver-intel.conf
に、
  Section "Device"
    Identifier "Card0"
    Driver "intel"
    BusID "PCI:0:2:0"
  EndSection
を追加。

そこで、startxしたところ、/var/log/Xorg.0.logに
  Failed to load /usr/local/lib/xorg/modules/drivers/intel_drv.so: 
/usr/local/lib/xorg/modules/drivers/intel_drv.so: invalid file format
が記録されていたので、なぜだかpkg installではうまくいかないのだという
ことで、ports/x11-drivers/xf86-video-intelからmakeしてinstall。

これで無事起動しました。

どうもありがとうございました。

※http://svnweb.freebsd.org/ports/head/UPDATING/?view=coをアンテナソフ
  トで見ていたのですが、httpsに代わったのに気がついていませんでした。
  そういえば、最近見ていなかったと、今更ながら気がつきました。^_^;;

青木和麻呂@国分寺市在住


【以下、全文引用】
From: Shigekazu KIMURA <zyxju...@gmail.com>
Subject: Re: X -> reset
Date: Sun, 23 Apr 2017 23:11:49 +0900

> 悸村と申します。
> 先月か今月に入ってから、うちでも xorg が起動しなくなるという現象が
> 起こりました。11.0R (amd64) を使用しています。
> 
> 私見では、X サーバーの変更が原因かも知れないと思います。
> https://www.freebsd.org/doc/ja_JP.eucJP/books/handbook/x-config.html
> 
> 自動検出するため、xorg.conf は必要ないと書いてあります。
> 
> 関連するのは以下の部分でしょうか。
> ports/UPDATING
>> 20170211:
>>  AFFECTS: users of x11-server/xorg-server
> 
> こちらでは、次の如き対処法を取りました。
> /etc/rc.conf で、dbus hald を無効にし…。
> xorg.conf をリネームし…。
> /boot/loader.conf で vt を設定し…。
> /usr/local/etc/X11/xorg.conf.d に driver-intel.conf や font.conf
> keyboard-layout.conf を作成し…。
> 起動するようになっています。
> 
> ただ、X 上のキーボードが日本語レイアウトにならず苦戦したのですが、
> これは使用している xfce 側で設定し、解決しました。
> 
> 違う原因で別の現象が発生しているなら、勘違いですので、ご容赦ください。
> 
> -- 
> 悸村成一
_______________________________________________
freebsd-users-jp@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-users-jp
To unsubscribe, send any mail to "freebsd-users-jp-unsubscr...@freebsd.org"

メールによる返信