いけさん です。

On Sat, 17 Dec 2005 02:03:44 +0900
[EMAIL PROTECTED] (Yoshihiko Sarumaru) wrote:

>   ということですが、/etc/make.conf で PERL_VER と PERL_VERSION
> は正しく 5.6.2 が設定されていますか? 

# added by use.perl 2005-12-16 21:54:17
PERL_VER=5.6.2
PERL_VERSION=5.6.2
NOPERL=yes

 とあります。

> ( cd /usr/ports/converters/p5-MIME-Base64 && make -V PERL5)
> とやると、なにがでますか?

/usr/local/bin/perl5.6.2

 となります。


>   ldd /usr/local/bin/perl すると libperl.so は何使ってますか。

# ldd /usr/local/bin/perl 
/usr/local/bin/perl:
        libperl.so => /usr/lib/libperl.so (0x28068000)
        libm.so.2 => /usr/lib/libm.so.2 (0x28100000)
        libcrypt.so.2 => /usr/lib/libcrypt.so.2 (0x2811b000)
        libutil.so.3 => /usr/lib/libutil.so.3 (0x28134000)
        libc_r.so.4 => /usr/lib/libc_r.so.4 (0x2813d000)

 となります。

>   LD_LIBRARY_PATH を設定していませんか。

 PostgreSQL のガイドに沿って設定しています。

 LD_LIBRARY_PATH を外して再度 p5-MIME-Base64-3.07 を make してみましたが、

===>  Configuring for p5-MIME-Base64-3.07
Perl 5.006 required--this is only version 5.00503, stopped at ./Makefile.PL 
line 1.
*** Error code 255

 となり、変化はありませんでした。

メールによる返信