みなさんはじめまして、やまざきと申します。

2.x以来久しぶりにFreeBSDをインストールしてみました。
PCカードのLANが使えません。インターネットを使って自分なりにいろいろと
情報を検索してみたのですが、どうにも解決できませんでしたので識者の方に
ヒントを頂こうと思いメールしてみました。

以下に断片的ではありますが必要そうな情報を示しますので、調査の進め方に
ついてアドバイスをいただければ幸いです。

- 環境など
バージョン: 5.4-RELEASE
カーネル: cbb,pccard,cardbusをコメントアウト、pcic,cardを追加、その他
不要と思われるものを削除。
マシン: TOSHIBA DynaBook TECRA740CT/2.1 Windows95モデル
BIOS設定: PCIC Compatible
PCカード: BAFFALO LPC2-CLT

- 現象
カードを挿すと以下のメッセージが出ます。ifconfigコマンドで確認してみた
ところplip0とlo0しかなくネットワークインターフェイスとして認識されてい
ないようです。

----ここから画面を見ながら手打ちで転記----
pccard: card inserted, slot 0
Jan 13 22:21:36  pccardd[175]: Card "BAFFALO"("LPC2-CLT") [R01] []
mached "BAFFALO" ("LPC2-CLT") [(null)] [(null)]
Jan 13 22:21:41  pccardd[175]: driver allocation failed for
BAFFALO(LPC2-CLT): Device not configured
----転記ここまで----

- カードは問題ないか?
LPC2-CLTを他のWindowsパソコンに挿すと正常に動作します。

- PCカードスロットは問題ないか?
TECRAにcorega WL PCCL-11を挿すとwi0として認識され、問題なく動作しま
す。

- dmesg

----dmesgここから----
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993,
1994
 The Regents of the University of California. All rights reserved.
FreeBSD 5.4-RELEASE #3: Fri Jan 13 22:01:52 JST 2006
    root@:/usr/src/sys/i386/compile/TECRA
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Pentium/P55C (166.19-MHz 586-class CPU)
  Origin = "GenuineIntel"  Id = 0x544  Stepping = 4
  Features=0x8001bf<FPU,VME,DE,PSE,TSC,MSR,MCE,CX8,MMX>
real memory  = 84017152 (80 MB)
avail memory = 76738560 (73 MB)
Intel Pentium detected, installing workaround for F00F bug
npx0: <math processor> on motherboard
npx0: INT 16 interface
cpu0 on motherboard
apm0: <APM BIOS> on motherboard
apm0: found APM BIOS v1.2, connected at v1.2
pcib0: <Host to PCI bridge> pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
pci0: <display, VGA> at device 4.0 (no driver attached)
isa0: <ISA bus> on motherboard
orm0: <ISA Option ROM> at iomem 0xc0000-0xcbfff on isa0
pmtimer0 on isa0
ata0 at port 0x3f6,0x1f0-0x1f7 irq 14 on isa0
ata1 at port 0x376,0x170-0x177 irq 15 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x64,0x60 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model GlidePoint, device ID 0
fdc0: <NEC 765 or clone> at port 0x3f0-0x3f5 irq 6 drq 2 on isa0
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
pcic0: <Intel i82365SL-A/B> at port 0x3e0 iomem 0xd0000 on isa0
pcic0: Polling mode
pccard0: <PC Card 16-bit bus (classic)> on pcic0
pccard1: <PC Card 16-bit bus (classic)> on pcic0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <TOS7400> can't assign resources (irq)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0600> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0401> can't assign resources (port)
Timecounters tick every 10.000 msec
ad0: 38154MB <IC25N040ATCS04-0/CA4OA71A> [77520/16/63] at ata0-master
PIO4
Mounting root from ufs:/dev/ad0s2a
----dmesgここまで----


以上、よろしくお願いいたします。

メールによる返信