滋賀県の福家と申します.

日頃から皆様のメールを拝見させていただいて勉強になっております.

さて,今回メールいたしましたのは自力で解決できない問題が
発生したためです.下記メッセージを見ていただければ
わかると思いますが,portupgradeが以下のエラーを吐いて
1つも更新されないまま止まってしまいます.

Rubyが悪いのか,他のパッケージが悪いのか原因がよくわかりません.

OSはFreeBSD4.11-STABLE #0と古いのでバージョンアップしろと
言われるかもしれませんが,遠隔地のレンタルサーバであって
バージョンアップに失敗して起動しなくなったら結構お金が
かかりますのと,サービスが止められないのでバージョンアップは見送っています.
(4から5へのバージョンアップは面倒だと聞いたこともありますので)
rubyは1.8.4 (2005-12-24) [i386-freebsd4]を使用しております.

mail# date ; cvsup /etc/cvsup/ports-supfile ; portupgrade -a
Fri Jun 30 23:15:12 JST 2006
Connected to cvsup2.jp.FreeBSD.org
Updating collection ports-all/cvs
Finished successfully
/usr/libexec/ld-elf.so.1: 
/usr/local/lib/ruby/site_ruby/1.8/i386-freebsd4/bdb.so: Undefined symbol 
"db_version_4002"

dbが対応していないと言われているのだと思いますが,
対処方法がわかりません.

いたらない点もあると思いますがよろしくお願いいたします.

PS.portupgradeってrubyで書かれていたのですね.
  てっきりCなどで書かれていてバイナリだと思っていました.

-----
福家哲夫(Fuke Tetsuo)<[EMAIL PROTECTED]>

メールによる返信