滋賀県の福家です.

助けてくださってありがとうございます.

On Sun, 2 Jul 2006 11:47:01 +0900
石井 <[EMAIL PROTECTED]> さんwrote:

> 直前のアップデートをいつ頃されたのかは分かりませんが、先
> ず portupgrade だけをアップデートされてから、再度やって
> みてはいかがでしょう。(おそらく ruby18-bdb もアップデー
> トされる)

/usr/ports/sysutils/portupgradeにて
make deinstall; make clean ; make installしたら
今度は違うメッセージが出てきました.
mail# portupgrade -a
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... uninitialized 
constant PkgDB::BDB;
 rebuild needed] [Rebuilding the pkgdb <format:bdb_btree> in /var/db/pkg ... 
Stale depen
dency: ldconfig_compat-1.0_8 <-- portupgrade-2.1.3.1,2 -- manually run 'pkgdb 
-F' to fix,or specify -O to force.
mail# pkgdb -F
--->  Checking the package registry database
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... uninitialized 
constant PkgDB::BD
B; rebuild needed] [Rebuilding the pkgdb <format:bdb_btree> in /var/db/pkg ... 
uninitializ
ed constant PkgDB::BDB: Cannot update the pkgdb!]: Cannot update the pkgdb!]

PkgDB::BDBが入っていないのかな?と思っていますが,
解決方法がわかりません.

> ところで、”kernel だけしか STABLE にしてない”と言う事
> はありませんよね。

はい,
mail# cvsup /etc/cvsup/stable-supfile
したあとmake world; make install しています

お手数をおかけしますが,よろしくお願いします.

-----
福家哲夫(Fuke Tetsuo)<[EMAIL PROTECTED]>

メールによる返信