お世話になります。内藤です。
長文にて失礼します。

今回Xorgを6.9から7.2に上げたところ、Xが起動しなくなりました。
Xorg.0.logを見たところエラー行が以下の通りになっていますが、解決方法が解
りません。
そこで、皆さんのお力をお借りしたいのですが、何か解る方いらっしゃるでしょ
うか?

<xorg.0.log抜粋>
(II) I810(0): Allocated 16 kB for HW (ARGB) cursor at 0x7ffb000
(II) I810(0): Allocated 4 kB for Overlay registers at 0x7ffa000 (0x5d1aa000).
(II) I810(0): Allocated 64 kB for the scratch buffer at 0x7fea000
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
[drm] failed to load kernel module "i915"
(II) I810(0): [drm] drmOpen failed
(EE) I810(0): [dri] DRIScreenInit failed. Disabling DRI.
(II) I810(0): 0x81e4130: Memory at offset 0x00020000, size 14848 kBytes
(II) I810(0): 0x81e1a80: Memory at offset 0x07fff000, size 4 kBytes
(II) I810(0): 0x81e1aa0: Memory at offset 0x07ffb000, size 16 kBytes

ビデオはチップセット内蔵i845Gです。以前はi810のドライバで動いていました。

なお、Xorgを7.2に上げた時に行ったのは以下の事です。

ports/UPDATINGに則り作業。portupgradeが全てdoneで終了したのを確認済み。
マイグレーションで以下のファイルがコンフリクトを起こしていたので内容を確
認して削除。

CONFLICTING FILES:
./etc/settings/.qt_plugins_3.3rc.lock
./etc/settings/qt_plugins_3.3rc
./lib/X11/fonts/TrueType/fonts.alias
./lib/X11/fonts/TrueType/fonts.dir
./man/whatis

無事、マイグレーションが終わったので、Xorg -configureでxorg.confを作り直
そうとするがi810やキーボードドライバが無いと言われたので、
x11-drivers/xorg-driversとx11-fonts/xorg-fontsをインストール。

Xorg -configure終了。
# mv ~/xorg.conf.new /etc/X11/xorg.conf

<以下xorg.conf>
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/local/share/X11/rgb"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/"
        FontPath     "/usr/local/lib/X11/fonts/OTF"
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
        Load  "extmod"
        Load  "record"
        Load  "dbe"
        Load  "glx"
        Load  "GLcore"
        Load  "xtrap"
        Load  "dri"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                   # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "ColorKey"                  # <i>
        #Option     "CacheLines"                # <i>
        #Option     "Dac6Bit"                   # [<bool>]
        #Option     "DRI"                       # [<bool>]
        #Option     "NoDDC"                     # [<bool>]
        #Option     "ShowCache"                 # [<bool>]
        #Option     "XvMCSurfaces"              # <i>
        #Option     "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "i810"
        VendorName  "Intel Corporation"
        BoardName   "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics 
Device"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection


.xinitrcはKDEを起動でしたが差し替えて簡素な物にしてあります。

<.xinitrc>
#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/local/lib/X11/xinit/.Xresources
sysmodmap=/usr/local/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# start some nice programs
twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login

また、ログを見ると
AUDIT: Mon Jun  4 08:28:03 2007: 860 X: client 1 rejected from local host (uid 
0)
が100行くらい続いて
(WW) I810(0): Successfully set original devices
(WW) I810(0): Setting the original video mode instead of restoring
        the saved state
(WW) I810(0): Extended BIOS function 0x5f05 failed.
となるのも気になります。

ちなみにxorgcfgは起動しますが、こちらでxorg.confを作っても同様です。

なにか手がかりとなることが有れば些細なことでも構いませんのでご教授願えれ
ばと思います。


----------------------------------------------------------------------
   内 藤 貴 志  <[EMAIL PROTECTED]>

メールによる返信