On Sat, 21 Jul 2007 16:06:02 +0900
"EGUCHI Osamu " 
<[&#x30E1;&#x30FC;&#x30EB;&#x30A2;&#x30C9;&#x30EC;&#x30B9;&#x4FDD;&#x8B77;]> 
wrote:

> # gmake /var/db/pkg/xpdf-3.01_2.upgrade
> 
> の様な指定方法なら、更新版があるかどうかを調べるトリガーにできると思います。

# gmake /var/db/pkg/p5*

などの様に、perl 関連を一気に更新したいときなどに、この方法だと
うまくいかないのです。

make には .PHONY を使うと、強制的に実行させるコマンドを作ることもできるので、
その使い方次第だと思っています。

# 以前に、試したときは失敗して、全ての再構築が始まってしまいました。

太田

メールによる返信