稲員です。

On Fri, 10 Sep 2010 07:57:39 +0900
S.Kimura (木村成一) <rikim...@a011.broada.jp> wrote:

> インストールした xemacs ですが、別の問題が存在します。
> japanese/xemacs21-canna はそのままだとファイルのオープンや dired に失敗するようです。
> editors/xemacs-packages をインストールすれば解決するのですが……。

  $ pkg_info -d xemacs-mule-packages-4.6
  (中略)
      This port provides a set of the mule-packages category packages provided 
by
  xemacs.org(www.xemacs.org). You should be used with editors/xemacs-packages.

とあるので、「普通入れるよね」とは思っているけど敢て DEPEND は
してないんですかね? 理由は分かりませんが。
でも editors/{xemacs,xemacs-devel} は DEPEND しているので、実は
単にあまりメンテナンスされてないだけなのかも。

> Makefile に RUN_DEPEND を追加しようとしたら、巧くいきませんでした。関係するファイルを
> 全部列挙する必要があるのかも知れないようです。

詳細が書かれていないのでアレなんですが、察するに japanese/xemacs21-canna/Makefile
の方に書いたという事ですか? もしそうなら、確かにそれだと上手く
いかないと思います。 理由は master port の方の Makefile である
editors/xemacs21-mule/Makefile を読めば分かるのではないかと思い
ますが。


-- 
Rikito INAKAZU (稲員力士) <riki1017k...@gmail.com>

メールによる返信