Hi to all.
I'd like to implement a little virtual network using QEMU 0.10.2, but, until 
now, I have failed.
This is the situation.
Host: AMD 64 running FreeBSD 7.2
#ifconfig
nfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=10b<RXCSUM,TXCSUM,VLAN_MTU,TSO4>
        ether 00:15:f2:44:2d:f9
        inet 192.168.0.2 netmask 0xffffff00 broadcast 192.168.0.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
        inet6 ::1 prefixlen 128 
        inet 127.0.0.1 netmask 0xff000000 
I've create an image using the FreeBSD 7.2 DVD:
#qemu-img create -f qcow2 hda fbsd72.img 10G
The image has been created.
#qemu -L /usr/local/share/qemu/ -cdrom /dev/acd0 -m 512 -boot d fbsd72.img
Alfter a long time, the installation of the guest system has been completed.
When the installation program asked for information about network 
configuration, as a first step, I chose DHCP configuration and, as usualy, the 
network has been set like this:
IP 10.0.2.15/255.255.255.0
gateway 10.0.2.2
nameserver 10.0.2.3
When the installation of the guest PC was finished, I've copied the image to 
pc01.img, to keep the original untouched. After that I've started qemu like 
this:
#qemu -L /usr/local/share/qemu -localtime -net nic,macaddr=00:15:f2:44:2d:01 
-net socket,mcast=230.0.0.1:1234 -hda pc01.img -cdrom /dev/acd0 &
but the network in the guest system does not work.
ifconfig in the guest system tells:
#ifconfig -a
ed0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  ether 00:15:f2:44:2d:01
  media: Ethernet 10baseT/UTP <full-duplex>
plip0: ...
lo0: ...
If I try:
#ping 10.0.2.2 (the gateway)
all packets are lost. For this reason, I've tryed a static IP configuration 
like this:
IP 10.0.2.4/255.255.255.0
gateway 10.0.2.2
nameserver 10.0.2.3
but the gateway does not respond. So it is useless to try with a second guest 
system.
Please help. Sorry for my bad english.
Marco
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to