( hoping this is the appropriate list)

We want to test FreeBSD 9.0 for a variety of different purposes. For now, we need to place this under VMware 4.x.

The port is an older release, 8.6, where the latest release is 8.8.2.x. The port will not compile properly (sent error output to port maintainer). I brought down the current release to give this a shot, not really knowing the extent and relevancy (yet) of the patches in the port version.

The initial configure flags I used are:

 ./configure --disable-unity --without-gtkmm

I ran into what may be a relatively simple error (below) regarding a deprecated <sys/timeb.h> issue.

Before I pull more hair out trying to get this working, I figured I would just ask and see if someone has solved the problems :-)

Correspondence with our official support channels with VMWare suggest that FreeBSD 9 is not supported yet, and will be in the TBD 5.1 release of VMWare. So, that means don't hold your breath ;-)

Thanks in advance!

libtool: compile: gcc -DPACKAGE_NAME=\"open-vm-tools\" -DPACKAGE_TARNAME=\"open-vm-tools\" -DPACKAGE_VERSION=\"8.8.2\" "-DPACKAGE_STRING=\"open-vm-tools 8.8.2\"" -DPACKAGE_BUGREPORT=\"open-vm-tools-de...@lists.sourceforge.net\" -DPACKAGE_URL=\"\" -DPACKAGE=\"open-vm-tools\" -DVERSION=\"8.8.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_X11_SM_SMLIB_H=1 -DHAVE_X11_ICE_ICELIB_H=1 -DHAVE_X11_EXTENSIONS_XCOMPOSITE_H=1 -DHAVE_DLOPEN=1 -DNO_PROCPS=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_WCHAR_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_USER_H=1 -DHAVE__BOOL=1 -DHAVE_STDBOOL_H=1 -DHAVE_STRUCT_STAT_ST_RDEV=1 -DTIME_WITH_SYS_TIME=1 -DNO_XSM=1 -DNO_XCOMPOSITE=1 -I. -I/home/faldrich/open-vm-tools-8.8.2-590212/lib/include -I/home/faldrich/open-vm-tools-8.8.2-590212/lib/include -DUSING_AUTOCONF=1 -DOPEN_VM_TOOLS -I/usr/local/include -I/usr/local/include -D_REENTRANT -I/usr/local/include -DUSE_ICU -DHAVE_ICU_38 -DVMX86_TOOLS -DNO_CORE_ICU -g -O2 -Wall -Werror -Wno-pointer-sign -Wno-unused-value -fno-strict-aliasing -Wno-unknown-pragmas -Wno-uninitialized -MT hostinfoPosix.lo -MD -MP -MF .deps/hostinfoPosix.Tpo -c hostinfoPosix.c -fPIC -DPIC -o .libs/hostinfoPosix.o
In file included from hostinfoPosix.c:34:
/usr/include/sys/timeb.h:42:2: error: #warning "this file includes <sys/timeb.h> which is deprecated"
*** Error code 1

Stop in /usr/home/faldrich/open-vm-tools-8.8.2-590212/lib/misc.
*** Error code 1

Stop in /usr/home/faldrich/open-vm-tools-8.8.2-590212/lib.
*** Error code 1

freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to