On 2/13/13 6:20 PM, Neel Natu wrote:
You'll need to set 'hw.pci.honor_msi_blacklist' to '0' at the loader
prompt or in /boot/loader.conf.


I am having these same issues with an 8.3-stable NanoBSD kernel I built. I tried it with and without all of the "depreciated" loader.conf variables like 'hw.pci.honor_msi_blacklist' Strangely, even copying in the kernel and virtio drivers from a known good system will not work.

I still get the errors below.

Suggestions on what else in the configuration might have an impact?

Michael


pcib0: no PRT entry for 0.31.INTA
virtio_pci0: <VirtIO PCI Network adapter> port 0x2000-0x201f at device 1.0 on pc
i0
vtnet0: <VirtIO Networking Adapter> on virtio_pci0
virtio_pci0: host features: 0x18020 <Status,MrgRxBuf,MacAddress>
virtio_pci0: negotiated features: 0x18020 <Status,MrgRxBuf,MacAddress>
virtio_pci0: cannot allocate interrupts
vtnet0: cannot allocate virtqueues
device_attach: vtnet0 attach returned 6
virtio_pci1: <VirtIO PCI Block adapter> port 0x2040-0x207f at device 2.0 on pci0
vtblk0: <VirtIO Block Adapter> on virtio_pci1
virtio_pci1: host features: 0x10000004 <RingIndirect,MaxNumSegs>
virtio_pci1: negotiated features: 0x10000004 <RingIndirect,MaxNumSegs>
virtio_pci1: cannot allocate interrupts
vtblk0: cannot allocate virtqueue
device_attach: vtblk0 attach returned 6
uart2: <16550 or compatible> port 0x3f8-0x3ff irq 4 at device 31.0 on pci0
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to