On 07/03/2013 12:36 AM, Vincent Hoffman wrote:
For what is worth I have -CURRENT and 9-STABLE KVM guests on a centos
6.4 KVM host.

[r...@nodule.namesco.net ~]# uname -a
Linux nodule.unsane.co.uk 2.6.32-358.11.1.el6.x86_64 #1 SMP Wed Jun 12
03:34:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
My libvirt is at, forgot to mention that.

So it certainly can work. I havent tested more than 4 CPUs that I can
think of. Havent had to do anything special.

Copyright (c) 1992-2013 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.1-STABLE #1 r252202: Tue Jun 25 12:30:35 BST 2013
     r...@ipamtest.unsane.co.uk:/usr/obj/usr/src/sys/GENERIC amd64
gcc version 4.2.1 20070831 patched [FreeBSD]
CPU: QEMU Virtual CPU version (cpu64-rhel6) (2333.39-MHz K8-class CPU)
   Origin = "GenuineIntel"  Id = 0x6d3  Family = 0x6  Model = 0xd
Stepping = 3
   AMD Features=0x20100800<SYSCALL,NX,LM>
   AMD Features2=0x1<LAHF>
When booted with a single cpu, it looks like this here:

CPU: Intel Core 2 Duo P9xxx (Penryn Class Core 2) (2493.74-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x623  Family = 6  Model = 2 Stepping = 3
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>

I used libvirts "copy host configuration" feature. (The CPUs are Xeon E5420, libvirt just seems to like to call them Core 2 Duo)
Translates into this command:

/usr/bin/qemu-system-x86_64 -machine accel=kvm -name iscsitarget -S -machine pc-i440fx-1.4,accel=kvm,usb=off -cpu Penryn,+dca,+pdcm,+xtpr,+tm2,+est,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 512 -smp 1,maxcpus=2,sockets=1,cores=2,threads=1 -uuid d7a0c1ec-3446-5bb9-57eb-dc081b3c7ddb -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/iscsitarget.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/dev/VMs/iscsitarget,if=none,id=drive-ide0-0-0,format=raw,cache=none,aio=native -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/var/lib/libvirt/images/FreeBSD-9.1-STABLE-amd64-20130630-r252387-bootonly.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=2 -netdev tap,fd=22,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:71:94:0f,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -vnc -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4

(sorry for the mess)

I have tried to manually set the cpu configuration to 1 socket, 2 cores, hoping this would fix it (shotgun debugging), but no luck.
I tried setting cpu to cpu64-rhel6 in libvirt, too - didn't help either.
At this point, the machine hangs for 1, 2sec when booting multi-cpu while with only one cpu, it goes straight on.
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 2 package(s) x 1 core(s)
  cpu0 (BSP): APIC ID:  0
  cpu1 (AP): APIC ID:  1
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <BOCHS BXPCRSDT> on motherboard
acpi0: Power Button (fixed)
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71,0x72-0x77 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0

A. V.
freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to