Using VirtualBox 4.2.20_2 (emulators/virtualbox-ose) on a 9.2-RELEASE
amd64 4 core (8 CPU with HT) host a FreeBSD 10.0-RC5 amd64 (also tested
with 3 and 4) VM with 4 allocated CPUs will repeatedly crashes when I
try to build a pkg repo with poudriere (ports-mgmt/poudriere) via the
bulk command.

>From the VM:
 root@freebsd10testing:~ # kldstat   #VirtualBox additions loaded (tested 
 Id Refs Address            Size     Name
  1    9 0xffffffff80200000 15f0310  kernel
  2    1 0xffffffff81a12000 22d50    vboxguest.ko
  3    1 0xffffffff81a35000 543      vboxvideo.ko
  4    1 0xffffffff81a36000 16d6c    drm.ko
 root@freebsd10testing:~ # sysctl hw.ncpu
 hw.ncpu: 4
 root@freebsd10testing:~ # uname -a
 FreeBSD freebsd10testing 10.0-RC5 FreeBSD 10.0-RC5 #0 r260430: Wed Jan 8 
05:10:04 UTC 2014  amd64
 root@freebsd10testing:~ # poudriere bulk -j testing www/firefox
 ====>> Creating the reference jail... done
 ====>> Mounting system devices for testing-default
 ====>> Mounting ports/packages/distfiles
 ====>> Mounting packages from: 
 ====>> Logs: 
 /etc/resolv.conf -> 
 ====>> Starting jail testing-default
 ====>> Calculating ports order and dependencies
 ====>> pkg package missing, skipping sanity
 ====>> Cleaning the build queue
 ====>> Building 145 packages using 4 builders
 ====>> Starting/Cloning builders
 mount_nullfs: /usr/local/poudriere/data/build/testing-default/03/usr/ports: 
Device not configured
 ====>> Error: Failed to mount the ports directory
 /usr/local/share/poudriere/ 5: Bad file descriptor
 Write failed: Broken pipe

At this point the ssh session dies (Write failed: Broken pipe) and the
VM restarts (watching the console via VNC).  The crash appears to occur
during the building of the reference jails (one per CPU - 4).

I don't see anything in /var/log/messages, /var/crash/ is empty, and savecore
doesn't dump any core files. 

I've tested this with 2, 3, 4, 5, and 6 CPUs allocated to the VM and it
crashes every time.  The only way I can have the VM not crash is with 1
allocated CPU.  I believe there's an issue with VirtualBox and FreeBSD
10.0 VM when the VM has multiple CPUs.

I don't think this is a poudriere issue however it's the only way I've been
able to crash the VM.  I've tried extracting multiple ports trees to different
locations at the same time thinking it's a disk issue because of the above
"Device not configured" (The/a disk disappears?) error, the VM didn't crash.

I've tried the same command with a FreeBSD 9.2-RELEASE amd64 4 CPU VM
under the same host with out any failure/crashes.

Could anyone confirm this with a multi-CPU VM and FreeBSD 10.0RC3/4/5 or
recommend any methods on how to debug this issue?
_______________________________________________ mailing list
To unsubscribe, send any mail to 

Reply via email to